[package] update tinc to 1.0.9, fix missing dependency against kmod-tun (#5651)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 9 Aug 2009 10:49:00 +0000 (10:49 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 9 Aug 2009 10:49:00 +0000 (10:49 +0000)
SVN-Revision: 17194

net/tinc/Makefile

index 216be5388820d04ef2c1added47f5524d539ec58..2eb4eca0c4ce7b4d6497ce0e44c48ffb9bc090e1 100644 (file)
@@ -8,26 +8,31 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinc
-PKG_VERSION:=1.0.8
+PKG_VERSION:=1.0.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages \
        http://ftp.yi.se/pub/tinc/ \
        http://www.mirrors.wiretapped.net/security/network-security/tinc/
-PKG_MD5SUM:=1b59583b5bc57806459c81a413fb0cc4
+PKG_MD5SUM:=f907acebada53512e01235bea6b4cdf1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/tinc
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+liblzo +libopenssl +zlib
+  DEPENDS:=+liblzo +libopenssl +kmod-tun
   TITLE:=VPN tunneling daemon
   URL:=http://www.tinc-vpn.org/
   SUBMENU:=VPN
 endef
 
+define Package/tinc/description
+  tinc is a Virtual Private Network (VPN) daemon that uses tunnelling and
+  encryption to create a secure private network between hosts on the Internet.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-kernel="$(LINUX_DIR)" \
@@ -42,7 +47,7 @@ define Build/Compile
                all install
 endef
 
-define Package/tinc/install    
+define Package/tinc/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tincd $(1)/usr/sbin/
 endef