Upgrade httping to 1.2.2 (#1414)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 27 Feb 2007 22:55:05 +0000 (22:55 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 27 Feb 2007 22:55:05 +0000 (22:55 +0000)
SVN-Revision: 6405

net/httping/Makefile
net/httping/patches/01-extra_flags.patch
net/httping/patches/02-version.patch

index e5d4d198658ddd8a9480b4d9ee1e039c8f93bc8a..7ff9733be3122aa9fbbee95889eb3b42e4fefe10 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.0.10
+PKG_VERSION:=1.2.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
-PKG_MD5SUM:=998b00b8babeb3196d28c20ad87d9c15
+PKG_MD5SUM:=cde335c0110fb1b156afdf80ff5ade1d
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
index 2c9038b9ac7bd8bc07df8611a5d68a8bf0f56c7d..86c75e743e3a9b2c079c4ede0ed225135d748bbe 100644 (file)
@@ -1,14 +1,14 @@
-diff -urN httping-1.0.10.orig/Makefile httping-1.0.10/Makefile
---- httping-1.0.10.orig/Makefile       2006-01-02 17:07:29.000000000 +0100
-+++ httping-1.0.10/Makefile    2006-02-13 13:44:45.066590304 +0100
+diff -ruaN httping-1.2.2.orig/Makefile httping-1.2.2/Makefile
+--- httping-1.2.2.orig/Makefile        2006-11-09 20:13:12.000000000 +0100
++++ httping-1.2.2/Makefile     2007-02-27 11:34:47.000000000 +0100
 @@ -15,8 +15,8 @@
- VERSION=1.0.10
+ include version
  
- DEBUG=-g
+ DEBUG=-g # -D_DEBUG
 -LDFLAGS+=-lssl -lcrypto $(DEBUG)
 -CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
 +LDFLAGS+=$(EXTRA_LDFLAGS) -lssl -lcrypto $(DEBUG)
 +CFLAGS+=$(EXTRA_CFLAGS) -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
  
- OBJS=http.o io.o str.o error.o utils.o main.o tcp.o mssl.o res.o
+ OBJS=mem.o http.o io.o str.o error.o utils.o main.o tcp.o mssl.o res.o
  
index 1a5db8e26bb284368ebc47ea00aa784a0bb4e8f7..a0589f1c2406d4c1d54e1a54867467bd4ce0c4b3 100644 (file)
@@ -1,16 +1,16 @@
-diff -urN httping-1.0.10/main.c httping-1.0.10.new/main.c
---- httping-1.0.10/main.c      2006-01-02 17:07:29.000000000 +0100
-+++ httping-1.0.10.new/main.c  2007-02-27 11:14:32.000000000 +0100
-@@ -38,6 +38,8 @@
+diff -ruaN httping-1.2.2.orig/main.c httping-1.2.2/main.c
+--- httping-1.2.2.orig/main.c  2006-11-09 20:13:12.000000000 +0100
++++ httping-1.2.2/main.c       2007-02-27 11:38:14.000000000 +0100
+@@ -40,6 +40,8 @@
  #include "utils.h"
  #include "error.h"
  
-+#define VERSION "1.0.10"
++#define VERSION "1.2.2"
 +
  static volatile int stop = 0;
  
  int quiet = 0;
-@@ -48,7 +50,7 @@
+@@ -50,7 +52,7 @@
  
  void version(void)
  {
@@ -19,12 +19,12 @@ diff -urN httping-1.0.10/main.c httping-1.0.10.new/main.c
  #ifndef NO_SSL
        fprintf(stderr, "SSL support included\n");
  #endif
-@@ -382,7 +384,7 @@
+@@ -413,7 +415,7 @@
        if (useragent)
                sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
        else
 -              sprintf(&request[strlen(request)], "User-Agent: HTTPing v" VERSION "\r\n");
 +              sprintf(&request[strlen(request)], "User-Agent: HTTPing v%s\r\n", VERSION);
+       sprintf(&request[strlen(request)], "Host: %s\r\n", hostname);
        if (referer)
                sprintf(&request[strlen(request)], "Referer: %s\r\n", referer);
-       strcat(request, "\r\n");