[package] fix chrony init script and bump package release number (#4718)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 7 Apr 2009 15:09:16 +0000 (15:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 7 Apr 2009 15:09:16 +0000 (15:09 +0000)
SVN-Revision: 15139

net/chrony/Makefile
net/chrony/files/ntpd.init

index 86a1c2e4d0cc7737d71d557d0e6abf549053a521..e07c1377bf8c3df0990ffff651abb6ea8914eeba 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=chrony
 PKG_VERSION:=1.23
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= ftp://chrony.sunsite.dk/projects/chrony/ \
index dd9c9f5d8fe9bba5f0eddc51cab05b1aa61b5bce..db8992db5a0822a10a876e51d3ed52a9a26274be 100644 (file)
@@ -12,8 +12,8 @@ start() {
                local CLIENT_NETWORKS
                local NETNAME
                config_load ntpd
-               config_get NTP_SERVERS cfg1 TimeServers
-               config_get CLIENT_NETWORKS cfg1 ClientAccessFrom
+               config_get NTP_SERVERS $cfg1 TimeServers
+               config_get CLIENT_NETWORKS $cfg1 ClientAccessFrom
                CHRONY_KEY=$(awk '/^1 / { print $2; }' /etc/chrony/chrony.keys)
                include /lib/network
                scan_interfaces
@@ -45,7 +45,7 @@ start() {
                                config_get INTERFACE "$NETNAME" ifname
                                if [ -n "$INTERFACE" ] ; then
                                        eval $(ifconfig $INTERFACE | grep inet | sed -e 's/.*addr:/IP=/' -e 's/ .*Mask:/; NETMASK=/')
-                                       eval $(ipcalc $IP $NETMASK)
+                                       eval $(ipcalc.sh $IP $NETMASK)
                                        echo allow $NETWORK/$PREFIX
                                fi
                        done