fix 2.4 build error introduced by changeset:2606
authorNicolas Thill <nico@openwrt.org>
Sun, 11 Dec 2005 21:13:08 +0000 (21:13 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 11 Dec 2005 21:13:08 +0000 (21:13 +0000)
SVN-Revision: 2613

openwrt/target/linux/package/spca5xx/Makefile
openwrt/target/linux/package/spca5xx/patches/01-kmod-build.patch

index 95a48a9a30eeefebd922363f3b851dc34df48023..d61a04a80c1713b9c9d42fd2acba89b9b512c049 100644 (file)
@@ -18,6 +18,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 ifeq ($(KERNEL_DIR),)
 KERNEL_DIR:=$(LINUX_DIR)
 endif
+KERNEL_VERSION=$(shell echo "$(LINUX_VERSION)" | cut -d. -f1,2)
 
 include $(TOPDIR)/package/rules.mk
 
index f69caf8b913a1ee999da05bec46595605a263778..eb7dccd32e5d19b0bf595a5850b6dc1559e13401 100644 (file)
@@ -26,7 +26,7 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
 -# This makefile will build the spca50x driver module external to the kernel
 -# source tree. It makes it easier to swap kernels.
 -
-+CFLAGS += $(DEFINES) 
++EXTRA_CFLAGS += $(DEFINES) 
  
 -KERNEL_VERSION = `uname -r`
 +spca5xx-objs := drivers/usb/spca5xx.o drivers/usb/spcadecoder.o