add quotes to TARGET_CC and TARGET_CROSS to help with distcc and ccache (yet again)
authorMike Baker <mbm@openwrt.org>
Fri, 4 Aug 2006 03:33:37 +0000 (03:33 +0000)
committerMike Baker <mbm@openwrt.org>
Fri, 4 Aug 2006 03:33:37 +0000 (03:33 +0000)
SVN-Revision: 4431

net/iftop/Makefile
net/igmpproxy/Makefile
net/irssi/Makefile
net/l2tpd/Makefile
net/l2tpns/Makefile
net/maradns/Makefile
utils/logrotate/Makefile

index 589dd217c9bc6c50111ba3e007d8d53c6a3af8ee..44501c700e9472205782b99dc6428571cc4aba46 100644 (file)
@@ -41,7 +41,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
+               CC="$(TARGET_CC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                install
 endef
index 3cda6fcbfed74a941977b32c219b1f0a3e8495c4..06620e7c524aeb2029216080d0694ce97c6f5998 100644 (file)
@@ -29,7 +29,7 @@ only IGMP signalling (Internet Group Management Protocol).\\\
 endef
 
 define Build/Compile   
-       $(MAKE) CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR)/src
+       $(MAKE) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR)/src
 endef
 
 
index 42a448c39b075afa3e3af9783404af46cf02b678..7613a42eac44a555960322126db3dd718506e7df 100644 (file)
@@ -47,7 +47,7 @@ endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC)
+               CC="$(TARGET_CC)"
 endef
 
 define Package/irssi/install   
index a3441ecd358c2a4ae625bb354d6a3b69d6565e7f..f478e722b164e78a25c7533a81ddcfe5fcbebf70 100644 (file)
@@ -42,7 +42,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CC=$(TARGET_CC) \
+               CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS) -I. -DLINUX -DSANITY -DIP_ALLOCATION"
 endef
 
index 2fc0dee23601debc221f0dcea1fa291e8112a2ec..d9498bf48406f80c90957728c3cb31a99b7a171b 100644 (file)
@@ -41,8 +41,8 @@ endef
        
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
-               LD=$(TARGET_CC) \
+               CC="$(TARGET_CC) \
+               LD=$(TARGET_CC)" \
                OPTIM="$(TARGET_CFLAGS)" \
                DESTDIR=$(PKG_INSTALL_DIR) \
                STAGING_DIR=$(STAGING_DIR) \
index d019f947dbaab859e891a2d50fed123bdbbc0d32..f06f0edacf1728529c21f823e5c0cff91ed80f94 100644 (file)
@@ -45,7 +45,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CFLAGS="$(TARGET_CFLAGS)" \
                FLAGS="$(TARGET_CFLAGS)" \
-               CC=$(TARGET_CC) \
+               CC="$(TARGET_CC)" \
                HOSTCC="$(HOSTCC)"
        mkdir -p $(PKG_INSTALL_DIR)/usr/{bin,sbin}
        mkdir -p $(PKG_INSTALL_DIR)/usr/man/man{1,5,8}
index 57f978bbaba5bcd1b99e0c42ecc7a2a59ada07d2..1bf28a215ea88c884b22dbdbc0276f5f60c5ad3f 100644 (file)
@@ -40,7 +40,7 @@ define Build/Compile
        make -C ${PKG_BUILD_DIR} \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               CC=$(TARGET_CC) logrotate
+               CC="$(TARGET_CC)" logrotate
 endef
 
 define Package/logrotate/install