[adm5120] image generation cleanups
authorGabor Juhos <juhosg@openwrt.org>
Tue, 29 Jan 2008 10:33:34 +0000 (10:33 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 29 Jan 2008 10:33:34 +0000 (10:33 +0000)
  * make image generation makefiles simpler
  * remove unused profiles
  * generate images for the Cellvision CAS-xxx/NFS-xxx devices

SVN-Revision: 10309

target/linux/adm5120/image/router_be.mk
target/linux/adm5120/image/router_le.mk
target/linux/adm5120/router_be/profiles/100-Texas.mk [deleted file]
target/linux/adm5120/router_be/profiles/110-Atheros.mk [deleted file]
target/linux/adm5120/router_le/profiles/100-Atheros.mk [deleted file]
target/linux/adm5120/router_le/profiles/105-Texas.mk [deleted file]
target/linux/adm5120/router_le/profiles/110-Ralink.mk [deleted file]
target/linux/adm5120/router_le/profiles/Cellvision.mk
target/linux/adm5120/router_le/profiles/Compex.mk
target/linux/adm5120/router_le/profiles/Conceptronic.mk [deleted file]
target/linux/adm5120/router_le/profiles/Edimax.mk

index 05f4b0073243d733134134820e39e82c61e1cddd..e9c1d40c85f3601bff408b965310d1b5c05ecfe5 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,71 +9,23 @@ define Image/Build/ZyXEL
        $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
 endef
 
        $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
 endef
 
-#
-# ZyXEL Prestige 334WT
-#
-define Image/Build/Board/P334WT
-       $(call Image/Build/ZyXEL,$(1),p-334wt)
-endef
-
-define Image/Build/Board/P334WT/squashfs
-       $(call Image/Build/Board/P334WT,squashfs)
-endef
-
-define Image/Build/Board/P334WT/jffs2-64k
-       $(call Image/Build/Board/P334WT,jffs2-64k)
-endef
-
-define Image/Build/Board/P334WT/Initramfs
-       $(call Image/Build/LZMAKernel/KArgs,p-334wt,bin)
-endef
-
-#
-# ZyXEL Prestige 335WT
-#
-define Image/Build/Board/P335WT
-       $(call Image/Build/ZyXEL,$(1),p-335wt)
-endef
-
-define Image/Build/Board/P335WT/squashfs
-       $(call Image/Build/Board/P335WT,$(1))
-endef
-
-define Image/Build/Board/P335WT/jffs2-64k
-       $(call Image/Build/Board/P335WT,$(1))
-endef
-
-define Image/Build/Board/P335WT/Initramfs
-       $(call Image/Build/LZMAKernel/KArgs,p-335wt,bin)
-endef
-
-#
-# Groups
-#
-define Image/Build/Group/All
-       $(call Image/Build/Board/P334WT/$(1))
-       $(call Image/Build/Board/P335WT/$(1))
+define Image/Build/Template/ZyXEL/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,$(1),gz)
 endef
 
 #
 # Profiles
 #
 endef
 
 #
 # Profiles
 #
-define Image/Build/Profile/Generic
-       $(call Image/Build/Group/All,$(1))
-endef
-
-define Image/Build/Profile/Atheros
-       $(call Image/Build/Group/All,$(1))
+define Image/Build/Profile/P334WT
+       $(call Image/Build/Template/ZyXEL/$(1),p-334wt)
 endef
 
 endef
 
-define Image/Build/Profile/Texas
-       $(call Image/Build/Group/All,$(1))
+define Image/Build/Profile/P335WT
+       $(call Image/Build/Template/ZyXEL/$(1),p-335wt)
 endef
 
 endef
 
-define Image/Build/Profile/P334WT
-       $(call Image/Build/Board/P334WT/$(1))
+define Image/Build/Profile/Generic
+       $(call Image/Build/Profile/P334WT,$(1))
+       $(call Image/Build/Profile/P335WT,$(1))
 endef
 
 endef
 
-define Image/Build/Profile/P335WT
-       $(call Image/Build/Board/P335WT/$(1))
-endef
index 4d91dbf014aca5bd648d683d3418b664e461880f..19ca4e3bf32c3c78a0c514d70c28d7146c6effd2 100644 (file)
@@ -50,6 +50,20 @@ define Image/Build/Infineon
        cat $(call imgname,$(1),$(2)).trx >> $(call imgname,$(1),$(2)).img
 endef
 
        cat $(call imgname,$(1),$(2)).trx >> $(call imgname,$(1),$(2)).img
 endef
 
+define Image/Build/Cellvision
+       $(call Image/Build/Loader,$(2),bin,0x80500000,0x6D8,y,$(3))
+       mkdir -p $(BIN_DIR)/tmp
+       cp $(KDIR)/loader-$(2).bin $(BIN_DIR)/tmp/vmlinux.bin
+       gzip -9 $(BIN_DIR)/tmp/vmlinux.bin
+       dd if=$(BIN_DIR)/tmp/vmlinux.bin.gz of=$(call imgname,$(1),$(2))-xmodem.bin bs=64k conv=sync
+       rm -rf $(BIN_DIR)/tmp
+       $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
+       cat $(call imgname,$(1),$(2)).trx >> $(call imgname,$(1),$(2))-xmodem.bin
+       $(STAGING_DIR_HOST)/bin/mkcasfw -B $(2) -d \
+               -K $(call imgname,$(1),$(2))-xmodem.bin \
+               $(call imgname,$(1),$(2))-webui.bin
+endef
+
 define Image/Build/Cellvision2
        # only for CAS-700/771/790/861
        $(call Image/Build/Loader,$(2),gz,0x80500000,0x6D8,y,$(2))
 define Image/Build/Cellvision2
        # only for CAS-700/771/790/861
        $(call Image/Build/Loader,$(2),gz,0x80500000,0x6D8,y,$(2))
@@ -72,481 +86,251 @@ define Image/Build/MyLoader
 endef
 
 #
 endef
 
 #
-# Cellvision CAS-700
-#
-define Image/Build/Board/CAS700
-       $(call Image/Build/Cellvision2,$(1),cas-700)
-endef
-
-define Image/Build/Board/CAS700/squashfs
-       $(call Image/Build/Board/CAS700,squashfs)
-endef
-
-define Image/Build/Board/CAS700/jffs2-64k
-       $(call Image/Build/Board/CAS700,jffs2-64k)
-endef
-
-define Image/Build/Board/CAS700/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,cas-700,gz)
-endef
-
-#
-# Cellvision CAS-700W
-#
-define Image/Build/Board/CAS700W
-       $(call Image/Build/Cellvision2,$(1),cas-700w)
-endef
-
-define Image/Build/Board/CAS700W/squashfs
-       $(call Image/Build/Board/CAS700W,squashfs)
-endef
-
-define Image/Build/Board/CAS700W/jffs2-64k
-       $(call Image/Build/Board/CAS700W,jffs2-64k)
-endef
-
-define Image/Build/Board/CAS700W/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,cas-700w,gz)
-endef
-
-#
-# Cellvision CAS-771
-#
-define Image/Build/Board/CAS771
-       $(call Image/Build/Cellvision2,$(1),cas-771)
-endef
-
-define Image/Build/Board/CAS771/squashfs
-       $(call Image/Build/Board/CAS771,squashfs)
-endef
-
-define Image/Build/Board/CAS771/jffs2-64k
-       $(call Image/Build/Board/CAS771,jffs2-64k)
-endef
-
-define Image/Build/Board/CAS771/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,cas-771,gz)
-endef
-
-#
-# Cellvision CAS-771W
-#
-define Image/Build/Board/CAS771W
-       $(call Image/Build/Cellvision2,$(1),cas-771w)
-endef
-
-define Image/Build/Board/CAS771W/squashfs
-       $(call Image/Build/Board/CAS771W,squashfs)
-endef
-
-define Image/Build/Board/CAS771W/jffs2-64k
-       $(call Image/Build/Board/CAS771W,jffs2-64k)
-endef
-
-define Image/Build/Board/CAS771W/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,cas-771w,gz)
-endef
-
-#
-# Cellvision CAS-790
+# Cellvision CAS-630/630W, CAS-670/670W, NFS-101U/101WU, NFS-202U/202WU
 #
 #
-define Image/Build/Board/CAS790
-       $(call Image/Build/Cellvision2,$(1),cas-790)
+define Image/Build/Template/Cellvision
+       $(call Image/Build/Cellvision,$(1),$(2),$(3))
 endef
 
 endef
 
-define Image/Build/Board/CAS790/squashfs
-       $(call Image/Build/Board/CAS790,squashfs)
+define Image/Build/Template/Cellvision/squashfs
+       $(call Image/Build/Template/Cellvision,squashfs,$(1),$(2))
 endef
 
 endef
 
-define Image/Build/Board/CAS790/jffs2-64k
-       $(call Image/Build/Board/CAS790,jffs2-64k)
-endef
-
-define Image/Build/Board/CAS790/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,cas-790,gz)
+define Image/Build/Template/Cellvision/jffs2-64k
+       $(call Image/Build/Template/Cellvision,jffs2-64k,$(1),$(2))
 endef
 
 #
 endef
 
 #
-# Cellvision CAS-861
+# Cellvision CAS-700/700W, CAS-771/771W, CAS-790, CAS-861/861W
 #
 #
-define Image/Build/Board/CAS861
-       $(call Image/Build/Cellvision2,$(1),cas-861)
+define Image/Build/Template/Cellvision2
+       $(call Image/Build/Cellvision2,$(1),$(2))
 endef
 
 endef
 
-define Image/Build/Board/CAS861/squashfs
-       $(call Image/Build/Board/CAS861,squashfs)
+define Image/Build/Template/Cellvision2/squashfs
+       $(call Image/Build/Template/Cellvision2,squashfs,$(1))
 endef
 
 endef
 
-define Image/Build/Board/CAS861/jffs2-64k
-       $(call Image/Build/Board/CAS861,jffs2-64k)
+define Image/Build/Template/Cellvision2/jffs2-64k
+       $(call Image/Build/Template/Cellvision2,jffs2-64k,$(1))
 endef
 
 endef
 
-define Image/Build/Board/CAS861/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,cas-861,gz)
+define Image/Build/Template/Cellvision2/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,$(1),gz)
 endef
 
 #
 endef
 
 #
-# Cellvision CAS-861W
+# Compex NP27G, NP28G, WP54G, WP54AG, WPP54G, WPP54AG
 #
 #
-define Image/Build/Board/CAS861W
-       $(call Image/Build/Cellvision2,$(1),cas-861w)
+define Image/Build/Template/Compex
+       $(call Image/Build/MyLoader,$(1),$(2))
 endef
 
 endef
 
-define Image/Build/Board/CAS861W/squashfs
-       $(call Image/Build/Board/CAS861W,squashfs)
+define Image/Build/Template/Compex/squashfs
+       $(call Image/Build/Template/Compex,squashfs,$(1))
 endef
 
 endef
 
-define Image/Build/Board/CAS861W/jffs2-64k
-       $(call Image/Build/Board/CAS861W,jffs2-64k)
+define Image/Build/Template/Compex/jffs2-64k
+       $(call Image/Build/Template/Compex,jffs2-64k,$(1))
 endef
 
 endef
 
-define Image/Build/Board/CAS861W/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,cas-861w,gz)
-endef
-
-#
-# Compex NP27G
-#
-define Image/Build/Board/NP27G
-       $(call Image/Build/MyLoader,$(1),np27g)
-endef
-
-define Image/Build/Board/NP27G/squashfs
-       $(call Image/Build/Board/NP27G,squashfs)
-endef
-
-define Image/Build/Board/NP27G/jffs2-64k
-       $(call Image/Build/Board/NP27G,jffs2-64k)
-endef
-
-define Image/Build/Board/NP27G/Initramfs
-       $(call Image/Build/LZMAKernel/Generic,np27g,bin)
-endef
-
-#
-# Compex NP28G
-#
-define Image/Build/Board/NP28G
-       $(call Image/Build/MyLoader,$(1),np28g)
-endef
-
-define Image/Build/Board/NP28G/squashfs
-       $(call Image/Build/Board/NP28G,squashfs)
-endef
-
-define Image/Build/Board/NP28G/jffs2-64k
-       $(call Image/Build/Board/NP28G,jffs2-64k)
-endef
-
-define Image/Build/Board/NP28G/Initramfs
-       $(call Image/Build/LZMAKernel/Generic,np28g,bin)
-endef
-
-#
-# Compex WP54G
-#
-define Image/Build/Board/WP54G
-       $(call Image/Build/MyLoader,$(1),wp54g)
-endef
-
-define Image/Build/Board/WP54G/squashfs
-       $(call Image/Build/Board/WP54G,squashfs)
-endef
-
-define Image/Build/Board/WP54G/jffs2-64k
-       $(call Image/Build/Board/WP54G,jffs2-64k)
-endef
-
-define Image/Build/Board/WP54G/Initramfs
-       $(call Image/Build/LZMAKernel/Generic,wp54g,bin)
-endef
-
-#
-# Compex WP54AG
-#
-define Image/Build/Board/WP54AG
-       $(call Image/Build/MyLoader,$(1),wp54ag)
-endef
-
-define Image/Build/Board/WP54AG/squashfs
-       $(call Image/Build/Board/WP54AG,squashfs)
-endef
-
-define Image/Build/Board/WP54AG/jffs2-64k
-       $(call Image/Build/Board/WP54AG,jffs2-64k)
-endef
-
-define Image/Build/Board/WP54AG/Initramfs
-       $(call Image/Build/LZMAKernel/Generic,wp54ag,bin)
-endef
-
-#
-# Compex WPP54G
-#
-define Image/Build/Board/WPP54G
-       $(call Image/Build/MyLoader,$(1),wpp54g)
-endef
-
-define Image/Build/Board/WPP54G/squashfs
-       $(call Image/Build/Board/WPP54G,squashfs)
-endef
-
-define Image/Build/Board/WPP54G/jffs2-64k
-       $(call Image/Build/Board/WPP54G,jffs2-64k)
-endef
-
-define Image/Build/Board/WPP54G/Initramfs
-       $(call Image/Build/LZMAKernel/Generic,wpp54g,bin)
-endef
-
-#
-# Compex WPP54AG
-#
-define Image/Build/Board/WPP54AG
-       $(call Image/Build/MyLoader,$(1),wpp54ag)
-endef
-
-define Image/Build/Board/WPP54AG/squashfs
-       $(call Image/Build/Board/WPP54AG,squashfs)
-endef
-
-define Image/Build/Board/WPP54AG/jffs2-64k
-       $(call Image/Build/Board/WPP54AG,jffs2-64k)
-endef
-
-define Image/Build/Board/WPP54AG/Initramfs
-       $(call Image/Build/LZMAKernel/Generic,wpp54ag,bin)
+define Image/Build/Template/Compex/Initramfs
+       $(call Image/Build/LZMAKernel/Generic,$(1),bin)
 endef
 
 #
 # Compex WP54G-WRT
 #
 endef
 
 #
 # Compex WP54G-WRT
 #
-define Image/Build/Board/WP54GWRT
+define Image/Build/Template/WP54GWRT
        $(call Image/Build/Compex,$(1),wp54g-wrt)
 endef
 
        $(call Image/Build/Compex,$(1),wp54g-wrt)
 endef
 
-define Image/Build/Board/WP54GWRT/squashfs
-       $(call Image/Build/Board/WP54GWRT,squashfs)
+define Image/Build/Template/WP54GWRT/squashfs
+       $(call Image/Build/Template/WP54GWRT,squashfs)
 endef
 
 endef
 
-define Image/Build/Board/WP54GWRT/jffs2-64k
-       $(call Image/Build/Board/WP54GWRT,jffs2-64k)
+define Image/Build/Template/WP54GWRT/jffs2-64k
+       $(call Image/Build/Template/WP54GWRT,jffs2-64k)
 endef
 
 endef
 
-define Image/Build/Board/WP54GWRT/Initramfs
+define Image/Build/Template/WP54GWRT/Initramfs
        $(call Image/Build/LZMAKernel/KArgs,wp54g-wrt,bin)
 endef
 
 #
        $(call Image/Build/LZMAKernel/KArgs,wp54g-wrt,bin)
 endef
 
 #
-# Edimax BR-6104K
-#
-define Image/Build/Board/BR6104K
-       $(call Image/Build/Edimax,$(1),br-6104k)
-endef
-
-define Image/Build/Board/BR6104K/squashfs
-       $(call Image/Build/Board/BR6104K,squashfs)
-endef
-
-define Image/Build/Board/BR6104K/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,br-6104k,gz)
-endef
-
-#
-# Edimax BR-6104KP
+# Edimax BR-6104K, BR-6104KP, BR-6104Wg, BR-6114WG
 #
 #
-define Image/Build/Board/BR6104KP
-       $(call Image/Build/Edimax,$(1),br-6104kp)
+define Image/Build/Template/Edimax
+       $(call Image/Build/Edimax,$(1),$(2))
 endef
 
 endef
 
-define Image/Build/Board/BR6104KP/squashfs
-       $(call Image/Build/Board/BR6104KP,squashfs)
+define Image/Build/Template/Edimax/squashfs
+       $(call Image/Build/Template/Edimax,squashfs,$(1))
 endef
 
 endef
 
-define Image/Build/Board/BR6104KP/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,br-6104kp,gz)
+define Image/Build/Template/Edimax/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,$(1),gz)
 endef
 
 #
 endef
 
 #
-# Edimax BR-6104WG
+# Infineon EASY 5120, EASY 83000
 #
 #
-define Image/Build/Board/BR6104WG
-       $(call Image/Build/Edimax,$(1),br-6104wg)
-endef
-
-define Image/Build/Board/BR6104WG/squashfs
-       $(call Image/Build/Board/BR6104WG,squashfs)
-endef
-
-define Image/Build/Board/BR6104WG/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,br-6104wg,gz)
+define Image/Build/Template/Infineon
+       $(call Image/Build/Infineon,$(1),$(2))
 endef
 
 endef
 
-#
-# Conceptronic C54BSR4
-#
-define Image/Build/Board/C54BSR4
-       $(call Image/Build/Edimax,$(1),c54bsr4)
+define Image/Build/Template/Infineon/squashfs
+       $(call Image/Build/Template/Infineon,squashfs,$(1))
 endef
 
 endef
 
-define Image/Build/Board/C54BSR4/squashfs
-       $(call Image/Build/Board/C54BSR4,squashfs)
+define Image/Build/Template/Infineon/jffs2-64k
+       $(call Image/Build/Template/Infineon,jffs2-64k,$(1))
 endef
 
 endef
 
-define Image/Build/Board/C54BSR4/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,c54bsr4,gz)
+define Image/Build/Template/Infineon/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,$(1),gz)
 endef
 
 #
 endef
 
 #
-# Infineon EASY 83000
+# Mikrotik RouterBOARD 1xx
 #
 #
-define Image/Build/Board/EASY83000
-       $(call Image/Build/Infineon,$(1),easy-83000)
-endef
-
-define Image/Build/Board/EASY83000/squashfs
-       $(call Image/Build/Board/EASY83000,squashfs)
-endef
-
-define Image/Build/Board/EASY83000/jffs2-64k
-       $(call Image/Build/Board/EASY83000,jffs2-64k)
-endef
-
-define Image/Build/Board/EASY83000/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,easy-83000,gz)
+define Image/Build/Template/Mikrotik/Initramfs
+       $(CP) $(KDIR)/vmlinux.elf $(call imgname,netboot,rb1xx)
 endef
 
 #
 endef
 
 #
-# Mikrotik RB-1xx
+# Profiles
 #
 #
-define Image/Build/Board/RB1xx/Initramfs
-       $(CP) $(KDIR)/vmlinux.elf $(call imgname,netboot,rb1xx)
+define Image/Build/Profile/CAS630
+       $(call Image/Build/Template/Cellvision/$(1),cas-630,cas-630)
 endef
 
 endef
 
-#
-# Groups
-#
-define Image/Build/Group/Cellvision
-       $(call Image/Build/Board/CAS700/$(1))
-       $(call Image/Build/Board/CAS700W/$(1))
-       $(call Image/Build/Board/CAS771/$(1))
-       $(call Image/Build/Board/CAS771W/$(1))
-       $(call Image/Build/Board/CAS790/$(1))
-       $(call Image/Build/Board/CAS861/$(1))
-       $(call Image/Build/Board/CAS861W/$(1))
+define Image/Build/Profile/CAS630W
+       $(call Image/Build/Template/Cellvision/$(1),cas-630,cas-630w)
 endef
 
 endef
 
-define Image/Build/Group/WP54G
-       $(call Image/Build/Board/WP54G/$(1))
-       $(call Image/Build/Board/WP54AG/$(1))
-       $(call Image/Build/Board/WPP54G/$(1))
-       $(call Image/Build/Board/WPP54AG/$(1))
-       $(call Image/Build/Board/WP54GWRT/$(1))
+define Image/Build/Profile/CAS670
+       $(call Image/Build/Template/Cellvision/$(1),cas-670,cas-670)
 endef
 
 endef
 
-define Image/Build/Group/Compex
-       $(call Image/Build/Board/NP27G/$(1))
-       $(call Image/Build/Board/NP28G/$(1))
-       $(call Image/Build/Group/WP54G,$(1))
+define Image/Build/Profile/CAS670W
+       $(call Image/Build/Template/Cellvision/$(1),cas-670,cas-670w)
 endef
 
 endef
 
-define Image/Build/Group/Conceptronic
-       $(call Image/Build/Board/C54BSR4/$(1))
+define Image/Build/Profile/NFS101U
+       $(call Image/Build/Template/Cellvision/$(1),nfs-101u,nfs-101u)
+       $(call Image/Build/Template/Cellvision/$(1),dn-7013,nfs-101u)
+       $(call Image/Build/Template/Cellvision/$(1),dns-120,nfs-101u)
+       $(call Image/Build/Template/Cellvision/$(1),mu-5000fs,nfs-101u)
+       $(call Image/Build/Template/Cellvision/$(1),tn-u100,nfs-101u)
 endef
 
 endef
 
-define Image/Build/Group/Edimax
-       $(call Image/Build/Board/BR6104K/$(1))
-       $(call Image/Build/Board/BR6104KP/$(1))
-       $(call Image/Build/Board/BR6104WG/$(1))
+define Image/Build/Profile/NFS101WU
+       $(call Image/Build/Template/Cellvision/$(1),nfs-101wu,nfs-101u)
+       $(call Image/Build/Template/Cellvision/$(1),dns-g120,nfs-101u)
 endef
 
 endef
 
-define Image/Build/Group/Infineon
-       $(call Image/Build/Board/EASY83000/$(1))
+define Image/Build/Profile/CAS700
+       $(call Image/Build/Template/Cellvision2/$(1),cas-700)
 endef
 
 endef
 
-define Image/Build/Group/All
-       $(call Image/Build/Group/Cellvision,$(1))
-       $(call Image/Build/Group/Compex,$(1))
-       $(call Image/Build/Group/Conceptronic,$(1))
-       $(call Image/Build/Group/Edimax,$(1))
-       $(call Image/Build/Group/Cellvision,$(1))
-       $(call Image/Build/Group/Infineon,$(1))
-       $(call Image/Build/Board/RB1xx/$(1))
+define Image/Build/Profile/CAS700W
+       $(call Image/Build/Template/Cellvision2/$(1),cas-700w)
 endef
 
 endef
 
-#
-# Profiles
-#
-define Image/Build/Profile/Generic
-       $(call Image/Build/Group/All,$(1))
+define Image/Build/Profile/CAS771
+       $(call Image/Build/Template/Cellvision2/$(1),cas-771)
 endef
 
 endef
 
-define Image/Build/Profile/Atheros
-       $(call Image/Build/AllBoards,$(1))
+define Image/Build/Profile/CAS771W
+       $(call Image/Build/Template/Cellvision2/$(1),cas-771w)
 endef
 
 endef
 
-define Image/Build/Profile/Texas
-       $(call Image/Build/AllBoards,$(1))
+define Image/Build/Profile/CAS790
+       $(call Image/Build/Template/Cellvision2/$(1),cas-790)
 endef
 
 endef
 
-define Image/Build/Profile/Ralink
-       $(call Image/Build/AllBoards,$(1))
+define Image/Build/Profile/CAS861
+       $(call Image/Build/Template/Cellvision2/$(1),cas-861)
 endef
 
 endef
 
-define Image/Build/Profile/WP54G
-       $(call Image/Build/Group/WP54G,$(1))
+define Image/Build/Profile/CAS861W
+       $(call Image/Build/Template/Cellvision2/$(1),cas-861w)
 endef
 
 define Image/Build/Profile/NP27G
 endef
 
 define Image/Build/Profile/NP27G
-       $(call Image/Build/Board/NP27G/$(1))
+       $(call Image/Build/Template/Compex/$(1),np27g)
 endef
 
 define Image/Build/Profile/NP28G
 endef
 
 define Image/Build/Profile/NP28G
-       $(call Image/Build/Board/NP28G/$(1))
-endef
-
-define Image/Build/Profile/CAS700
-       $(call Image/Build/Board/CAS700/$(1))
-endef
-
-define Image/Build/Profile/CAS700W
-       $(call Image/Build/Board/CAS700W/$(1))
+       $(call Image/Build/Template/Compex/$(1),np28g)
 endef
 
 endef
 
-define Image/Build/Profile/CAS771
-       $(call Image/Build/Board/CAS771/$(1))
+define Image/Build/Profile/WP54
+       $(call Image/Build/Template/Compex/$(1),wp54g)
+       $(call Image/Build/Template/Compex/$(1),wp54ag)
+       $(call Image/Build/Template/Compex/$(1),wpp54g)
+       $(call Image/Build/Template/Compex/$(1),wpp54ag)
+       $(call Image/Build/Template/WP54GWRT/$(1))
 endef
 
 endef
 
-define Image/Build/Profile/CAS771W
-       $(call Image/Build/Board/CAS771W/$(1))
-endef
-
-define Image/Build/Profile/CAS790
-       $(call Image/Build/Board/CAS790/$(1))
+define Image/Build/Profile/BR6104K
+       $(call Image/Build/Template/Edimax/$(1),br-6104k)
 endef
 
 endef
 
-define Image/Build/Profile/CAS861
-       $(call Image/Build/Board/CAS861/$(1))
+define Image/Build/Profile/BR6104KP
+       $(call Image/Build/Template/Edimax/$(1),br-6104kp)
 endef
 
 endef
 
-define Image/Build/Profile/CAS861W
-       $(call Image/Build/Board/CAS861W/$(1))
+define Image/Build/Profile/BR6104WG
+       $(call Image/Build/Template/Edimax/$(1),br-6104wg)
 endef
 
 endef
 
-define Image/Build/Profile/BR6104K
-       $(call Image/Build/Board/BR6104K/$(1))
+define Image/Build/Profile/BR6114WG
+       $(call Image/Build/Template/Edimax/$(1),br-6114wg)
 endef
 
 endef
 
-define Image/Build/Profile/BR6104KP
-       $(call Image/Build/Board/BR6104KP/$(1))
+define Image/Build/Profile/EASY83000
+       $(call Image/Build/Template/Infineon/$(1),easy-83000)
 endef
 
 endef
 
-define Image/Build/Profile/C54BSR4
-       $(call Image/Build/Board/C54BSR4/$(1))
+define Image/Build/Profile/RouterBoard
+       $(call Image/Build/Template/Mikrotik/$(1))
+endef
+
+ifeq ($(CONFIG_BROKEN),y)
+define Image/Build/Experimental
+       # Cellvison
+       $(call Image/Build/Profile/CAS630,$(1))
+       $(call Image/Build/Profile/CAS630W,$(1))
+       $(call Image/Build/Profile/CAS670,$(1))
+       $(call Image/Build/Profile/CAS670W,$(1))
+       $(call Image/Build/Profile/CAS700,$(1))
+       $(call Image/Build/Profile/CAS700W,$(1))
+       $(call Image/Build/Profile/CAS771,$(1))
+       $(call Image/Build/Profile/CAS771W,$(1))
+       $(call Image/Build/Profile/CAS861,$(1))
+       $(call Image/Build/Profile/CAS861W,$(1))
+       $(call Image/Build/Profile/NFS101U,$(1))
+       $(call Image/Build/Profile/NFS101WU,$(1))
 endef
 endef
+endif
 
 
-define Image/Build/Profile/RouterBoard
-       $(call Image/Build/Board/RB1xx/$(1))
+define Image/Build/Profile/Generic
+       # Compex
+       $(call Image/Build/Profile/WP54,$(1))
+       $(call Image/Build/Profile/NP27G,$(1))
+       $(call Image/Build/Profile/NP28G,$(1))
+       # Edimax
+       $(call Image/Build/Profile/BR6104K,$(1))
+       $(call Image/Build/Profile/BR6104KP,$(1))
+       $(call Image/Build/Profile/BR6104WG,$(1))
+       $(call Image/Build/Profile/BR6114WG,$(1))
+       # Infineon
+       $(call Image/Build/Profile/EASY83000,$(1))
+       # Mikrotik
+       $(call Image/Build/Profile/RB1xx/$(1))
+       $(call Image/Build/Experimental)
 endef
 
 ifeq ($(PROFILE),RouterBoard)
 endef
 
 ifeq ($(PROFILE),RouterBoard)
diff --git a/target/linux/adm5120/router_be/profiles/100-Texas.mk b/target/linux/adm5120/router_be/profiles/100-Texas.mk
deleted file mode 100644 (file)
index af17042..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Texas
-       NAME:=Texas Instruments WiFi
-       PACKAGES:=kmod-acx
-endef
-
-define Profile/Texas/Description
-       Package set compatible with hardware using Texas Instruments WiFi cards
-endef
-$(eval $(call Profile,Texas))
-
diff --git a/target/linux/adm5120/router_be/profiles/110-Atheros.mk b/target/linux/adm5120/router_be/profiles/110-Atheros.mk
deleted file mode 100644 (file)
index fa95bf3..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Atheros
-       NAME:=Atheros WiFi
-       PACKAGES:=kmod-madwifi
-endef
-
-define Profile/Atheros/Description
-       Package set compatible with hardware using Atheros WiFi cards.
-endef
-$(eval $(call Profile,Atheros))
-
diff --git a/target/linux/adm5120/router_le/profiles/100-Atheros.mk b/target/linux/adm5120/router_le/profiles/100-Atheros.mk
deleted file mode 100644 (file)
index 8ad626c..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Atheros
-       NAME:=Atheros WiFi
-       PACKAGES:=kmod-madwifi
-endef
-
-define Profile/Atheros/Description
-       Package set compatible with hardware using Atheros WiFi cards.
-endef
-
-$(eval $(call Profile,Atheros))
diff --git a/target/linux/adm5120/router_le/profiles/105-Texas.mk b/target/linux/adm5120/router_le/profiles/105-Texas.mk
deleted file mode 100644 (file)
index dff3baf..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Texas
-       NAME:=Texas Instruments WiFi
-       PACKAGES:=kmod-acx
-endef
-
-define Profile/Texas/Description
-       Package set compatible with hardware using Texas Instruments WiFi cards.
-endef
-$(eval $(call Profile,Texas))
-
diff --git a/target/linux/adm5120/router_le/profiles/110-Ralink.mk b/target/linux/adm5120/router_le/profiles/110-Ralink.mk
deleted file mode 100644 (file)
index f0a457d..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Ralink
-       NAME:=Ralink WiFi
-       PACKAGES:=kmod-rt2500
-endef
-
-define Profile/Ralink/Description
-       Package set compatible with hardware using Ralink WiFi cards.
-endef
-$(eval $(call Profile,Ralink))
index 218c2b5079854fd098b604c17f7349b011838da2..9450b881fde173d4b33ff087490f469881ce1207 100644 (file)
@@ -5,8 +5,44 @@
 # See /LICENSE for more information.
 #
 
 # See /LICENSE for more information.
 #
 
+define Profile/CAS630
+       NAME:=Cellvision CAS-630 IP camera (Experimental)
+       # TODO: add default packages
+endef
+
+define Profile/CAS630/Description
+       Package set optimized for the Cellvision CAS-630 device.
+endef
+
+define Profile/CAS630W
+       NAME:=Cellvision CAS-630W IP camera (Experimental)
+       # TODO: add default packages
+endef
+
+define Profile/CAS630W/Description
+       Package set optimized for the Cellvision CAS-630W device.
+endef
+
+define Profile/CAS670
+       NAME:=Cellvision CAS-670 IP camera (Experimental)
+       # TODO: add default packages
+endef
+
+define Profile/CAS670/Description
+       Package set optimized for the Cellvision CAS-670 device.
+endef
+
+define Profile/CAS670W
+       NAME:=Cellvision CAS-670W IP camera (Experimental)
+       # TODO: add default packages
+endef
+
+define Profile/CAS670W/Description
+       Package set optimized for the Cellvision CAS-670 device.
+endef
+
 define Profile/CAS700
 define Profile/CAS700
-       NAME:=Cellvision CAS-700 IP camera (Untested)
+       NAME:=Cellvision CAS-700 IP camera (Experimental)
        # TODO: add default packages
 endef
 
        # TODO: add default packages
 endef
 
@@ -15,7 +51,7 @@ define Profile/CAS700/Description
 endef
 
 define Profile/CAS700W
 endef
 
 define Profile/CAS700W
-       NAME:=Cellvision CAS-700W IP camera (Untested)
+       NAME:=Cellvision CAS-700W IP camera (Experimental)
        # TODO: add default packages
 endef
 
        # TODO: add default packages
 endef
 
@@ -24,7 +60,7 @@ define Profile/CAS700W/Description
 endef
 
 define Profile/CAS771
 endef
 
 define Profile/CAS771
-       NAME:=Cellvision CAS-771 IP camera (Untested)
+       NAME:=Cellvision CAS-771 IP camera (Experimental)
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
 endef
 
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
 endef
 
@@ -33,7 +69,7 @@ define Profile/CAS771/Description
 endef
 
 define Profile/CAS771W
 endef
 
 define Profile/CAS771W
-       NAME:=Cellvision CAS-771W IP camera (Untested)
+       NAME:=Cellvision CAS-771W IP camera (Experimental)
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500
 endef
 
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500
 endef
 
@@ -42,7 +78,7 @@ define Profile/CAS771W/Description
 endef
 
 define Profile/CAS790
 endef
 
 define Profile/CAS790
-       NAME:=Cellvision CAS-790 IP camera (Untested)
+       NAME:=Cellvision CAS-790 IP camera (Experimental)
        # TODO: add default packages
 endef
 
        # TODO: add default packages
 endef
 
@@ -51,7 +87,7 @@ define Profile/CAS790/Description
 endef
 
 define Profile/CAS861
 endef
 
 define Profile/CAS861
-       NAME:=Cellvision CAS-861 IP camera (Untested)
+       NAME:=Cellvision CAS-861 IP camera (Experimental)
        # TODO: add default packages
 endef
 
        # TODO: add default packages
 endef
 
@@ -60,7 +96,7 @@ define Profile/CAS861/Description
 endef
 
 define Profile/CAS861W
 endef
 
 define Profile/CAS861W
-       NAME:=Cellvision CAS-861W IP camera (Untested)
+       NAME:=Cellvision CAS-861W IP camera (Experimental)
        PACKAGES:=kmod-rt2500
 endef
 
        PACKAGES:=kmod-rt2500
 endef
 
@@ -68,6 +104,26 @@ define Profile/CAS861W/Description
        Package set optimized for the Cellvision CAS-861W device.
 endef
 
        Package set optimized for the Cellvision CAS-861W device.
 endef
 
+define Profile/NFS101U
+       NAME:=Cellvision NFS-101U Network File Server (Experimental)
+endef
+
+define Profile/NFS101U/Description
+       Package set optimized for the Cellvision NFS-101U device.
+endef
+
+define Profile/NFS101WU
+       NAME:=Cellvision NFS-101WU Network File Server (Experimental)
+endef
+
+define Profile/NFS101WU/Description
+       Package set optimized for the Cellvision NFS-101WU device.
+endef
+
+$(eval $(call Profile,CAS630))
+$(eval $(call Profile,CAS630W))
+$(eval $(call Profile,CAS670))
+$(eval $(call Profile,CAS670W))
 $(eval $(call Profile,CAS700))
 $(eval $(call Profile,CAS700W))
 $(eval $(call Profile,CAS771))
 $(eval $(call Profile,CAS700))
 $(eval $(call Profile,CAS700W))
 $(eval $(call Profile,CAS771))
@@ -75,3 +131,6 @@ $(eval $(call Profile,CAS771W))
 $(eval $(call Profile,CAS790))
 $(eval $(call Profile,CAS861))
 $(eval $(call Profile,CAS861W))
 $(eval $(call Profile,CAS790))
 $(eval $(call Profile,CAS861))
 $(eval $(call Profile,CAS861W))
+$(eval $(call Profile,NFS101U))
+$(eval $(call Profile,NFS101WU))
+
index 31ee31ea81c894f67df3ce9cda59a142ae39e826..4307b4ffd365618f8c857579acfe0e5053ef5143 100644 (file)
@@ -23,15 +23,15 @@ define Profile/NP28G/Description
        Package set optimized for the Compex NP28G.
 endef
 
        Package set optimized for the Compex NP28G.
 endef
 
-define Profile/WP54G
-       NAME:=Compex WP54G family
+define Profile/WP54
+       NAME:=Compex WP54 family
        PACKAGES:=kmod-madwifi
 endef
 
        PACKAGES:=kmod-madwifi
 endef
 
-define Profile/WP54G/Description
-       Package set optimized for the Compex WP54G family.
+define Profile/WP54/Description
+       Package set optimized for the Compex WP54 family.
 endef
 
 $(eval $(call Profile,NP27G))
 $(eval $(call Profile,NP28G))
 endef
 
 $(eval $(call Profile,NP27G))
 $(eval $(call Profile,NP28G))
-$(eval $(call Profile,WP54G))
+$(eval $(call Profile,WP54))
diff --git a/target/linux/adm5120/router_le/profiles/Conceptronic.mk b/target/linux/adm5120/router_le/profiles/Conceptronic.mk
deleted file mode 100644 (file)
index 7ba49ec..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/C54BSR4
-       NAME:=Conceptronic C54BSR4 (Unofficial)
-       PACKAGES:=kmod-net-ipw2200
-endef
-
-define Profile/C54BSR4/Description
-       Package set optimized for the C54BSR4
-endef
-
-$(eval $(call Profile,C54BSR4))
index 9b0ca65c2bbeead467ca531242670aa70992057c..e4c427f570584451ebded5dcb2ef8dcedbb3c833 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -22,5 +22,23 @@ define Profile/BR6104KP/Description
        Package set optimized for the Edimax BR-6104KP
 endef
 
        Package set optimized for the Edimax BR-6104KP
 endef
 
+define Profile/BR6104WG
+       NAME:=Edimax BR-6104Wg (Unofficial, No WiFi)
+endef
+
+define Profile/BR6104WG/Description
+       Package set optimized for the Edimax BR-6104Wg
+endef
+
+define Profile/BR6114WG
+       NAME:=Edimax BR-6114WG (Unofficial, No WiFi)
+endef
+
+define Profile/BR6114WG/Description
+       Package set optimized for the Edimax BR-6114WG
+endef
+
 $(eval $(call Profile,BR6104K))
 $(eval $(call Profile,BR6104KP))
 $(eval $(call Profile,BR6104K))
 $(eval $(call Profile,BR6104KP))
+$(eval $(call Profile,BR6104WG))
+$(eval $(call Profile,BR6114WG))