DirectFB: change package name as upper-case characters in package names result in...
authorMirko Vogt <mirko@openwrt.org>
Mon, 10 May 2010 17:54:02 +0000 (17:54 +0000)
committerMirko Vogt <mirko@openwrt.org>
Mon, 10 May 2010 17:54:02 +0000 (17:54 +0000)
SVN-Revision: 21418

libs/libdirectfb/Makefile

index 7eddc5590445eaec82e5a21739b8dc7a600079b6..47220e6ac093e29eb7e2d10e9a3dd7cd48cf2036 100644 (file)
@@ -20,7 +20,7 @@ PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/DirectFB
+define Package/directfb
     TITLE:=DirectFB
     SECTION:=libs
     CATEGORY:=Libraries
@@ -28,7 +28,7 @@ define Package/DirectFB
     DEPENDS:=+libpng +libjpeg +libpthread +libfreetype
 endef
 
-define Package/DirectFB/description
+define Package/directfb/description
     DirectFB is a thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system with support for translucent windows and multiple display layers, not only on top of the Linux Framebuffer Device. It is a complete hardware abstraction layer with software fallbacks for every graphics operation that is not supported by the underlying hardware.
 endef
 
@@ -74,7 +74,7 @@ define Build/InstallDev
                $(1)/usr/lib/
 endef
 
-define Package/DirectFB/install
+define Package/directfb/install
        $(INSTALL_DIR) \
                $(1)/usr/bin \
                $(1)/usr/lib \
@@ -111,4 +111,4 @@ define Package/DirectFB/install
 endef
 
 $(eval $(call Feature,DirectFB))
-$(eval $(call BuildPackage,DirectFB))
+$(eval $(call BuildPackage,directfb))