ipsec-tools: Fix compile on linux-2.6.36
authorMichael Büsch <mb@bu3sch.de>
Sun, 10 Oct 2010 14:14:57 +0000 (14:14 +0000)
committerMichael Büsch <mb@bu3sch.de>
Sun, 10 Oct 2010 14:14:57 +0000 (14:14 +0000)
SVN-Revision: 23378

net/ipsec-tools/Makefile

index 9bbd2a569738bd0bf1909588c6ff95ed747d3b7b..1248b546c56ecdebfe04b47ee76b30bfa9eec2ab 100644 (file)
@@ -42,6 +42,10 @@ CONFIGURE_ARGS += \
        --enable-natt \
        --enable-adminport
 
        --enable-natt \
        --enable-adminport
 
+# override CFLAGS holding "-Werror" that break builds on compile warnings
+MAKE_FLAGS+=\
+       CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS)"
+
 define Build/Prepare
        $(call Build/Prepare/Default)
        chmod -R u+w $(PKG_BUILD_DIR)
 define Build/Prepare
        $(call Build/Prepare/Default)
        chmod -R u+w $(PKG_BUILD_DIR)
@@ -59,8 +63,6 @@ define Build/Configure
        echo "#undef HAVE_SHADOW_H" >> $(PKG_BUILD_DIR)/config.h
 endef
 
        echo "#undef HAVE_SHADOW_H" >> $(PKG_BUILD_DIR)/config.h
 endef
 
-# override CFLAGS holding "-Werror" that break builds on compile warnings
-
 define Package/ipsec-tools/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/racoon/samples/racoon.conf $(1)/etc/
 define Package/ipsec-tools/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/racoon/samples/racoon.conf $(1)/etc/