[packages] ucarp: fix hardcoded paths to binaries (#7345)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 17 May 2010 20:05:32 +0000 (20:05 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 17 May 2010 20:05:32 +0000 (20:05 +0000)
SVN-Revision: 21496

net/ucarp/Makefile
net/ucarp/files/ucarp.init

index 63051cb01e4d93ef9c73511bc12622bd8e8014ab..67afdfc3032ffafdd6ae758ae64023695c0403a3 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ucarp
 PKG_VERSION:=1.5.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.pureftpd.org/pub/ucarp
index aa8ad9f7054b388a65b7c23d8627279354198105..c00baf4b63c28e440dc5444330c2b2384b4c721e 100644 (file)
@@ -2,6 +2,9 @@
 
 START=50
 CONF=/etc/ucarp.conf
+IP=$(which ip)
+UCARP=$(which ucarp)
+ARPING=$(which arping)
 
 start() {
        . ${CONF}
@@ -11,13 +14,13 @@ start() {
        cat > /var/run/ucarp-vip-up <<EOF
 #!/bin/sh
 
-/bin/ip addr add ${VIP}/${VMASK} dev ${IF}
+$IP addr add ${VIP}/${VMASK} dev ${IF}
 
 EOF
        for ip in ${PINGIP}
        do
        cat >> /var/run/ucarp-vip-up <<EOF
-/usr/bin/arping -c 2 -I ${IF} -s ${VIP} ${ip}
+$ARPING -c 2 -I ${IF} -s ${VIP} ${ip}
 EOF
        done
        chmod a+x /var/run/ucarp-vip-up
@@ -25,12 +28,12 @@ EOF
        cat > /var/run/ucarp-vip-down <<EOF
 #!/bin/sh
 
-/bin/ip addr del ${VIP}/${VMASK} dev ${IF}
+$IP addr del ${VIP}/${VMASK} dev ${IF}
 
 EOF
        chmod a+x /var/run/ucarp-vip-down
 
-       /usr/sbin/ucarp --interface=${IF} --srcip=${MYIP} --vhid=1 --pass=${PASSWORD} \
+       $UCARP --interface=${IF} --srcip=${MYIP} --vhid=1 --pass=${PASSWORD} \
                        --addr=${VIP} --nomcast $daemon \
                        --upscript=/var/run/ucarp-vip-up --downscript=/var/run/ucarp-vip-down
 }