[packages] lighttpd: update to 1.4.29, add patch for OpenSSL's disabled elliptic...
authorStephen Walker <stephendwalker@gmail.com>
Fri, 22 Jul 2011 19:52:13 +0000 (19:52 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Fri, 22 Jul 2011 19:52:13 +0000 (19:52 +0000)
SVN-Revision: 27726

net/lighttpd/Makefile
net/lighttpd/patches/001-no_ec.patch [new file with mode: 0644]

index e2d5598e61dc1e3a529a121911af3bf2d1c30e34..29cf5bfc0b94e5c1c4062fb220a462101c19daef 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
-PKG_VERSION:=1.4.28
+PKG_VERSION:=1.4.29
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x/
-PKG_MD5SUM:=586eb535d31ac299652495b058dd87c4
+PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x
+PKG_MD5SUM:=e6e67b09986cb504db630b5a86b2dd76
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
diff --git a/net/lighttpd/patches/001-no_ec.patch b/net/lighttpd/patches/001-no_ec.patch
new file mode 100644 (file)
index 0000000..45cf0ff
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/src/network.c
++++ b/src/network.c
+@@ -480,9 +480,11 @@ int network_init(server *srv) {
+       network_backend_t backend;
+ #if OPENSSL_VERSION_NUMBER >= 0x0090800fL
++#ifndef OPENSSL_NO_ECDH
+       EC_KEY *ecdh;
+       int nid;
+ #endif
++#endif
+ #ifdef USE_OPENSSL
+       DH *dh;