packages: nginx: fix libopenssl dependency
authorJonas Gorski <jogo@openwrt.org>
Sun, 12 May 2013 10:51:22 +0000 (10:51 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 12 May 2013 10:51:22 +0000 (10:51 +0000)
The build system doesn't understand this compound DEPENDS condition
without it being wrapped in parentheses. menuconfig does understand it, so
libopenssl would be selected if nginx needed it, but there was no
guarantee that openssl would be built before nginx. Adding parentheses
fixes the problem. This seems to be how compound conditions are generally
handled in OpenWrt Makefiles.

Signed-off-by: Mark Mentovai <mark@moxienet.com>
SVN-Revision: 36606

net/nginx/Makefile

index 4ec78c2e29ffb76bf9fec07cb6198daff51bee7c..31d9318fdbca757bbac21dd6c364fb56b9f775a3 100644 (file)
@@ -57,7 +57,7 @@ define Package/nginx
   SUBMENU:=Web Servers/Proxies
   TITLE:=Nginx web server
   URL:=http://nginx.org/
-  DEPENDS:=+NGINX_PCRE:libpcre +NGINX_SSL||NGINX_HTTP_CACHE||NGINX_HTTP_AUTH_BASIC:libopenssl +NGINX_HTTP_GZIP:zlib +libpthread +NGINX_LUA:liblua
+  DEPENDS:=+NGINX_PCRE:libpcre +(NGINX_SSL||NGINX_HTTP_CACHE||NGINX_HTTP_AUTH_BASIC):libopenssl +NGINX_HTTP_GZIP:zlib +libpthread +NGINX_LUA:liblua
   MENU:=1
 endef