[packages] collectd: fix fp-layout on big-endian targets (closes: #7707)
authorNicolas Thill <nico@openwrt.org>
Sat, 14 Aug 2010 23:40:04 +0000 (23:40 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 14 Aug 2010 23:40:04 +0000 (23:40 +0000)
SVN-Revision: 22653

utils/collectd/Makefile

index 69007d80d6e526eacde844e560e774e3975cf7ca..ff1ebf046527a30fc3eb40dc3a10427924030358 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=collectd
 PKG_VERSION:=4.9.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://collectd.org/files/
@@ -145,7 +145,6 @@ CONFIGURE_ARGS+= \
        --enable-daemon \
        --enable-getifaddrs \
        --with-nan-emulation \
-       --with-fp-layout=nothing
 
 CONFIGURE_VARS+= \
        CFLAGS="$$$$CFLAGS $(FPIC)" \
@@ -167,6 +166,12 @@ ifneq ($(CONFIG_PACKAGE_collectd-mod-ascent),)
        CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/libxml2"
 endif
 
+ifneq ($(CONFIG_BIG_ENDIAN),)
+  CONFIGURE_ARGS+= --with-fp-layout=endianflip
+else
+  CONFIGURE_ARGS+= --with-fp-layout=nothing
+endif
+
 ifneq ($(CONFIG_PACKAGE_collectd-mod-postgresql),)
   CONFIGURE_ARGS+= --with-libpq="$(STAGING_DIR)/usr/"
 endif