rename libgphoto2 patch, add patch to remove the tests/ build - should fix the buildb...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 3 Oct 2006 12:46:16 +0000 (12:46 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 3 Oct 2006 12:46:16 +0000 (12:46 +0000)
SVN-Revision: 4891

libs/libgphoto2/patches/01-no_nls_bug.patch [deleted file]
libs/libgphoto2/patches/010-no_nls_bug.patch [new file with mode: 0644]
libs/libgphoto2/patches/020-remove_tests.patch [new file with mode: 0644]

diff --git a/libs/libgphoto2/patches/01-no_nls_bug.patch b/libs/libgphoto2/patches/01-no_nls_bug.patch
deleted file mode 100644 (file)
index 23480d6..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
---- libgphoto2-2.2.1-old/camlibs/sonix/library.c       2006-04-18 18:54:18.000000000 -0700
-+++ libgphoto2-2.2.1/camlibs/sonix/library.c   2006-07-31 09:02:45.000000000 -0700
-@@ -41,7 +41,7 @@
- #else
- #  define _(String) (String)
- #  define N_(String) (String)
--#  define ngettext(String1,String2,Count) ((Count==1)?String1:String)
-+#  define ngettext(String1,String2,Count) ((Count==1)?String1:String2)
- #endif
- #include <gphoto2-port.h>
-
---- libgphoto2-2.2.1-old/libgphoto2_port/libgphoto2_port/gphoto2-port-info-list.c      2006-06-03 08:38:12.000000000 -0700
-+++ libgphoto2-2.2.1/libgphoto2_port/libgphoto2_port/gphoto2-port-info-list.c  2006-07-31 09:04:36.000000000 -0700
-@@ -51,6 +51,7 @@
- #  define dgettext(Domain,Message) (Message)
- #  define dcgettext(Domain,Message,Type) (Message)
- #  define bindtextdomain(Domain,Directory) (Domain)
-+#  define bind_textdomain_codeset(Domain,Codeset) (Codeset)
- #  define _(String) (String)
- #  define N_(String) (String)
- #endif
-@@ -79,7 +80,7 @@
- const char*
- gp_port_message_codeset (const char *codeset) {
--      return bind_textdomain_codeset (GETTEXT_PACKAGE, codeset);
-+      return codeset;
- }
- /**
-
---- libgphoto2-2.2.1-old/packaging/generic/print-camera-list.c 2006-04-18 18:54:05.000000000 -0700
-+++ libgphoto2-2.2.1/packaging/generic/print-camera-list.c     2006-07-31 09:02:45.000000000 -0700
-@@ -48,8 +48,8 @@
- #include <time.h>
- #include <string.h>
--#include <gphoto2/gphoto2-camera.h>
--#include <gphoto2/gphoto2-port-log.h>
-+#include <libgphoto2/gphoto2-camera.h>
-+#include <libgphoto2_port/gphoto2-port-log.h>
- #ifndef TRUE
- #define TRUE  (0==0)
diff --git a/libs/libgphoto2/patches/010-no_nls_bug.patch b/libs/libgphoto2/patches/010-no_nls_bug.patch
new file mode 100644 (file)
index 0000000..23480d6
--- /dev/null
@@ -0,0 +1,45 @@
+--- libgphoto2-2.2.1-old/camlibs/sonix/library.c       2006-04-18 18:54:18.000000000 -0700
++++ libgphoto2-2.2.1/camlibs/sonix/library.c   2006-07-31 09:02:45.000000000 -0700
+@@ -41,7 +41,7 @@
+ #else
+ #  define _(String) (String)
+ #  define N_(String) (String)
+-#  define ngettext(String1,String2,Count) ((Count==1)?String1:String)
++#  define ngettext(String1,String2,Count) ((Count==1)?String1:String2)
+ #endif
+ #include <gphoto2-port.h>
+
+--- libgphoto2-2.2.1-old/libgphoto2_port/libgphoto2_port/gphoto2-port-info-list.c      2006-06-03 08:38:12.000000000 -0700
++++ libgphoto2-2.2.1/libgphoto2_port/libgphoto2_port/gphoto2-port-info-list.c  2006-07-31 09:04:36.000000000 -0700
+@@ -51,6 +51,7 @@
+ #  define dgettext(Domain,Message) (Message)
+ #  define dcgettext(Domain,Message,Type) (Message)
+ #  define bindtextdomain(Domain,Directory) (Domain)
++#  define bind_textdomain_codeset(Domain,Codeset) (Codeset)
+ #  define _(String) (String)
+ #  define N_(String) (String)
+ #endif
+@@ -79,7 +80,7 @@
+ const char*
+ gp_port_message_codeset (const char *codeset) {
+-      return bind_textdomain_codeset (GETTEXT_PACKAGE, codeset);
++      return codeset;
+ }
+ /**
+
+--- libgphoto2-2.2.1-old/packaging/generic/print-camera-list.c 2006-04-18 18:54:05.000000000 -0700
++++ libgphoto2-2.2.1/packaging/generic/print-camera-list.c     2006-07-31 09:02:45.000000000 -0700
+@@ -48,8 +48,8 @@
+ #include <time.h>
+ #include <string.h>
+-#include <gphoto2/gphoto2-camera.h>
+-#include <gphoto2/gphoto2-port-log.h>
++#include <libgphoto2/gphoto2-camera.h>
++#include <libgphoto2_port/gphoto2-port-log.h>
+ #ifndef TRUE
+ #define TRUE  (0==0)
diff --git a/libs/libgphoto2/patches/020-remove_tests.patch b/libs/libgphoto2/patches/020-remove_tests.patch
new file mode 100644 (file)
index 0000000..6273bc8
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ur libgphoto.old/Makefile.am libgphoto.dev/Makefile.am
+--- libgphoto.old/Makefile.am  2006-04-19 03:54:32.000000000 +0200
++++ libgphoto.dev/Makefile.am  2006-10-03 14:40:18.000000000 +0200
+@@ -8,7 +8,7 @@
+ EXTRA_DIST = HACKING MAINTAINERS makefile.os2 os2mak.inc TESTERS CHANGES
+ # Note: @subdirs@ lists all the directories from AC_CONFIG_SUBDIRS()
+-SUBDIRS = @subdirs@ libgphoto2 camlibs tests po packaging doc
++SUBDIRS = @subdirs@ libgphoto2 camlibs po packaging doc
+ doc_DATA = AUTHORS COPYING README CHANGES NEWS
+diff -ur libgphoto.old/Makefile.in libgphoto.dev/Makefile.in
+--- libgphoto.old/Makefile.in  2006-06-19 21:15:59.000000000 +0200
++++ libgphoto.dev/Makefile.in  2006-10-03 14:40:23.000000000 +0200
+@@ -297,7 +297,7 @@
+ EXTRA_DIST = HACKING MAINTAINERS makefile.os2 os2mak.inc TESTERS CHANGES
+ # Note: @subdirs@ lists all the directories from AC_CONFIG_SUBDIRS()
+-SUBDIRS = @subdirs@ libgphoto2 camlibs tests po packaging doc
++SUBDIRS = @subdirs@ libgphoto2 camlibs po packaging doc
+ doc_DATA = AUTHORS COPYING README CHANGES NEWS
+ ########################################################################