add luaprofiler
authorFelix Fietkau <nbd@openwrt.org>
Sat, 15 Nov 2008 13:20:47 +0000 (13:20 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 15 Nov 2008 13:20:47 +0000 (13:20 +0000)
SVN-Revision: 13219

lang/luaprofiler/Makefile [new file with mode: 0644]
lang/luaprofiler/patches/100-link.patch [new file with mode: 0644]

diff --git a/lang/luaprofiler/Makefile b/lang/luaprofiler/Makefile
new file mode 100644 (file)
index 0000000..b79a9fc
--- /dev/null
@@ -0,0 +1,55 @@
+# 
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=luaprofiler
+PKG_VERSION:=2.0.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://luaforge.net/frs/download.php/3400
+PKG_MD5SUM:=611435c8e61e1a330ee0aa8ddc9c124a
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/luaprofiler
+  SUBMENU:=LUA
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Lua Profiler
+  URL:=http://luaprofiler.luaforge.net
+endef
+
+define Package/luaprofiler/description
+ Profile any Lua application
+endef
+
+define Build/Configure
+
+endef
+
+TARGET_CFLAGS += $(FPIC) \
+       -I$(STAGING_DIR)/usr/include
+
+TARGET_LDFLAGS += -llua
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               -f Makefile.linux
+endef
+
+define Package/luaprofiler/install
+       $(INSTALL_DIR) $(1)/usr/lib/lua
+       $(CP) $(PKG_BUILD_DIR)/bin/profiler.so $(1)/usr/lib/lua/
+endef
+
+$(eval $(call BuildPackage,luaprofiler))
diff --git a/lang/luaprofiler/patches/100-link.patch b/lang/luaprofiler/patches/100-link.patch
new file mode 100644 (file)
index 0000000..804e39c
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile.linux
++++ b/Makefile.linux
+@@ -4,7 +4,7 @@ OBJS= src/clocks.o src/core_profiler.o s
+ profiler: $(OBJS)
+-      mkdir -p bin && $(LD) -Bshareable -o $(PROFILER_OUTPUT) $(OBJS)
++      mkdir -p bin && $(LD) -Bshareable -o $(PROFILER_OUTPUT) $(OBJS) $(LDFLAGS)
+ clean:
+       rm -f $(PROFILER_OUTPUT) src/*.o