[PATCH] ahcpd: fix ticket 3550
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Apr 2009 16:06:57 +0000 (16:06 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Apr 2009 16:06:57 +0000 (16:06 +0000)
Signed-off-by: Gabriel Kerneis <kerneis@pps.jussieu.fr>
SVN-Revision: 15266

ipv6/ahcpd/Makefile
ipv6/ahcpd/files/ahcpd.config
ipv6/ahcpd/files/ahcpd.init

index a983d32ee91a651b42769d23d75f2e403fb081c2..870d8bab83e0403f7573b58f49ed6fa2a5fcd2ed 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ahcpd
 PKG_VERSION:=0.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
index 4aca869712c6d8fee5e1e60a535ec107661e3e2b..58db58bc5b6a033f223993f2687f3b51744c0ff8 100755 (executable)
@@ -1,5 +1,4 @@
 config ahcpd
        option interfaces "wl0"
-       # Comment out to actually disable, see ticket 3550
        option no_dns false
        option no_ipv4 true
index a885c5477b56de617f4b13fae11be7a8484874eb..efd80d3c4270d4d76bdb0256b59623aa93d72d45 100644 (file)
@@ -7,8 +7,8 @@ pidfile=/var/run/ahcpd.pid
 ahcpd_config() {
        local cfg="$1"
        config_get interfaces "$cfg" interfaces
-       config_get no_ipv4 "$cfg" no_ipv4
-       config_get no_dns "$cfg" no_dns
+       config_get_bool no_ipv4 "$cfg" no_ipv4 0
+       config_get_bool no_dns "$cfg" no_dns 0
 }
 
 start() {
@@ -16,6 +16,12 @@ start() {
        config_foreach ahcpd_config ahcpd
        mkdir -p /var/lib
        [ -r /usr/lib/ahcp/ahcp.dat ] && authority="-a /usr/lib/ahcp/ahcp.dat"
+       if [ "$no_ipv4" -eq 0 ]; then
+               unset no_ipv4
+       fi
+       if [ "$no_dns" -eq 0 ]; then
+               unset no_dns
+       fi
        if [ -e $pidfile ] ; then
                echo "$pidfile exists -- not starting ahcpd." >&2
        else