fix click compile
authorFelix Fietkau <nbd@openwrt.org>
Fri, 4 Aug 2006 18:58:33 +0000 (18:58 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 4 Aug 2006 18:58:33 +0000 (18:58 +0000)
SVN-Revision: 4441

net/click/Makefile
net/click/patches/100-compile_fix.patch [new file with mode: 0644]

index 31c98c594df0a8016a8358c75c8f2d3f4a2e038a..4e88b31ac283180ca47a12f1f9a3387c7f595ed3 100644 (file)
@@ -41,9 +41,13 @@ define Package/roofnet
   URL:=http://pdos.csail.mit.edu/roofnet/
 endef
 
+CONF_OPTS= \
+               ac_cv_int64_t=no \
+               ac_cv_sizeof_off_t=4
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
+               $(CONF_OPTS) \
                ./configure; \
                cp include/click/config.h include/click/config-host.h; \
                rm -rf config.{cache,status} ; \
@@ -52,6 +56,7 @@ define Build/Configure
                CFLAGS="-static -MD" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               $(CONF_OPTS) \
                ./configure \
                  --prefix=/usr \
                  --target=$(GNU_TARGET_NAME) \
@@ -68,6 +73,7 @@ endef
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
+       $(CONF_OPTS) \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                BUILD_CXX="g++ -include $(PKG_BUILD_DIR)/include/click/config-host.h" \
                tools elementmap.xml
diff --git a/net/click/patches/100-compile_fix.patch b/net/click/patches/100-compile_fix.patch
new file mode 100644 (file)
index 0000000..75a669c
--- /dev/null
@@ -0,0 +1,46 @@
+diff -urN click.old/configure click.dev/configure
+--- click.old/configure        2006-03-02 17:51:04.000000000 +0100
++++ click.dev/configure        2006-08-04 20:40:20.518827296 +0200
+@@ -6689,23 +6689,8 @@
+ echo "$as_me:$LINENO: result: $ac_cv_uint64_t" >&5
+ echo "${ECHO_T}$ac_cv_uint64_t" >&6
+-    have_int64_types=
+     if test $ac_cv_int64_t = no -o $ac_cv_uint64_t = no; then
+-      { { echo "$as_me:$LINENO: error:
+-=========================================
+-
+-int64_t types not defined by $inttypes_hdr!
+-Compile with '--disable-int64'.
+-
+-=========================================" >&5
+-echo "$as_me: error:
+-=========================================
+-
+-int64_t types not defined by $inttypes_hdr!
+-Compile with '--disable-int64'.
+-
+-=========================================" >&2;}
+-   { (exit 1); exit 1; }; }
++    have_int64_types=
+     else
+ cat >>confdefs.h <<\_ACEOF
+diff -urN click.old/m4/click.m4 click.dev/m4/click.m4
+--- click.old/m4/click.m4      2006-03-02 17:51:06.000000000 +0100
++++ click.dev/m4/click.m4      2006-08-04 20:40:49.953352568 +0200
+@@ -536,13 +536,7 @@
+     have_int64_types=
+     if test $ac_cv_int64_t = no -o $ac_cv_uint64_t = no; then
+-      AC_MSG_ERROR([
+-=========================================
+-
+-int64_t types not defined by $inttypes_hdr!
+-Compile with '--disable-int64'.
+-
+-=========================================])
++      have_int64_types=no
+     else
+       AC_DEFINE([HAVE_INT64_TYPES], [1], [Define if 64-bit integer types are enabled.])
+       have_int64_types=yes