[package] base-files: now that the initial password is completely empty (and not...
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 11 Nov 2011 13:25:31 +0000 (13:25 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 11 Nov 2011 13:25:31 +0000 (13:25 +0000)
SVN-Revision: 28943

package/base-files/Makefile
package/base-files/files/bin/login.sh

index da9e6f3727296e795783262543ce93e3e4ad382c..c515dcf7b16c633752fdc75dda499a67183ca168 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=92
+PKG_RELEASE:=93
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index a64c84e1e2dc918086cbadad0b78366a29cd7f09..b46769a012912259109c893bc26fbb1ab796a742 100755 (executable)
@@ -1,7 +1,7 @@
 #!/bin/sh
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
-if grep -qs '^root:[^!]' /etc/passwd /etc/shadow && [ -z "$FAILSAFE" ]; then
+if grep -qs '^root:[^!:]' /etc/passwd /etc/shadow && [ -z "$FAILSAFE" ]; then
        echo "Login failed."
        exit 0
 else