packages/zabbix: use common CONFIGURE_ARGS var, cleanup
authorNicolas Thill <nico@openwrt.org>
Thu, 14 Oct 2010 12:41:29 +0000 (12:41 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 14 Oct 2010 12:41:29 +0000 (12:41 +0000)
SVN-Revision: 23438

admin/zabbix/Makefile

index 378922ba7c4fc305d20c67631f330ffdbfd60ba1..7fd99a5d2f54b7120808f9ce37232605ff165dac 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,10 +10,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=zabbix
 PKG_VERSION:=1.6
 PKG_RELEASE:=2
-PKG_MD5SUM:=39d4c871439b1b4f0429964b4abbfc45
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/zabbix
+PKG_MD5SUM:=39d4c871439b1b4f0429964b4abbfc45
 
 PKG_BUILD_DEPENDS:=libsqlite3
 PKG_INSTALL:=1
@@ -50,24 +50,18 @@ ifneq ($(SDK),)
 CONFIG_PACKAGE_zabbix-server:=m
 endif
 
-PKG_CONFIGURE_OPTIONS:= \
+CONFIGURE_ARGS+= \
        --bindir="/usr/sbin" \
        --enable-agent
 
 ifneq ($(CONFIG_PACKAGE_zabbix-server),)
-PKG_CONFIGURE_OPTIONS+= \
+  CONFIGURE_ARGS+= \
        --enable-server \
        --with-sqlite3="$(STAGING_DIR)/usr"
 endif
 
 MAKE_FLAGS += ARCH="linux"
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               $(PKG_CONFIGURE_OPTIONS) \
-       )
-endef
-
 define Package/zabbix-agent/conffiles
 /etc/zabbix/zabbix_agentd.conf
 endef