bridge: Fix multicast_to_unicast feature by hairpin+isolate
[project/netifd.git] / CMakeLists.txt
index 632d1b9480b734bee420c92c8938164a862fd402..85527bec08c370a53ff215d02cb18991bed9d3bc 100644 (file)
@@ -15,12 +15,11 @@ SET(SOURCES
        interface.c interface-ip.c interface-event.c
        iprule.c proto.c proto-static.c proto-shell.c
        config.c device.c bridge.c vlan.c alias.c
-       macvlan.c ubus.c)
+       macvlan.c ubus.c vlandev.c wireless.c)
 
 
-find_library(json NAMES json-c json)
 SET(LIBS
-       ubox ubus uci ${json} blobmsg_json)
+       ubox ubus uci json-c blobmsg_json)
 
 IF (NOT DEFINED LIBNL_LIBS)
   FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)