netifd: Activate -Wextra compile warnings
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 12 Feb 2023 20:02:08 +0000 (21:02 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 19 Feb 2023 15:11:06 +0000 (16:11 +0100)
This activates some more compile warnings.
-pedantic is not yet activated, then we see too many errors which I do
not know how to mitigate.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
CMakeLists.txt

index b3bf411880f6f22936ac9af05f0d1389ff180a02..b87c300fcc221a20cc047d56e8a4911ce4622508 100644 (file)
@@ -7,7 +7,11 @@ IF(NOT ${CMAKE_VERSION} LESS 3.0)
   check_c_compiler_flag(-Wimplicit-fallthrough HAS_IMPLICIT_FALLTHROUGH)
 ENDIF()
 
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-unknown-warning-option -Wno-format-truncation)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-unused-parameter -Wno-unused-but-set-parameter)
+IF(CMAKE_C_COMPILER_VERSION VERSION_GREATER 6)
+       add_definitions(-Wextra -Werror=implicit-function-declaration)
+       add_definitions(-Wformat -Werror=format-security -Werror=format-nonliteral)
+ENDIF()
 
 IF(HAS_IMPLICIT_FALLTHROUGH)
   ADD_DEFINITIONS(-Wimplicit-fallthrough)