ar71xx: image: rework EnGenius ENS202EXT factory image
authorPiotr Dymacz <pepe2k@gmail.com>
Mon, 15 Jan 2018 12:30:19 +0000 (13:30 +0100)
committerPiotr Dymacz <pepe2k@gmail.com>
Mon, 15 Jan 2018 12:39:54 +0000 (13:39 +0100)
Current EnGenius ENS202EXT factory image recipe version causes factory
images of the following devices to be corrupted. This issue wasn't
visible until recent changes of image Makefile snippets order.

Signed-off-by: Mathias Kresin <dev@kresin.me>
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
target/linux/ar71xx/image/generic-senao.mk

index dbb7b69f94735ffe148e851fabd7d2b837f47532..3a7f6776b3411c56d20ebd926977bfb01c26428c 100644 (file)
@@ -1,12 +1,9 @@
 define Build/senao-factory-image
-       $(eval board=$(word 1,$(1)))
-       $(eval rootfs=$(word 2,$(1)))
-
        mkdir -p $@.senao
 
-       touch $@.senao/FWINFO-OpenWrt-$(REVISION)-$(board)
-       $(CP) $(IMAGE_KERNEL) $@.senao/openwrt-senao-$(board)-uImage-lzma.bin
-       $(CP) $(rootfs) $@.senao/openwrt-senao-$(board)-root.squashfs
+       touch $@.senao/FWINFO-OpenWrt-$(REVISION)-$(1)
+       $(CP) $(IMAGE_KERNEL) $@.senao/openwrt-senao-$(1)-uImage-lzma.bin
+       $(CP) $@ $@.senao/openwrt-senao-$(1)-root.squashfs
 
        $(TAR) -c \
                --numeric-owner --owner=0 --group=0 --sort=name \
@@ -25,7 +22,7 @@ define Device/ens202ext
   IMAGE_SIZE := 13632k
   IMAGES += factory.bin
   MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),320k(custom)ro,1536k(kernel),12096k(rootfs),2048k(failsafe)ro,64k(art)ro,13632k@0xa0000(firmware)
-  IMAGE/factory.bin/squashfs := append-rootfs | pad-rootfs | senao-factory-image ens202ext $$$$@
+  IMAGE/factory.bin := append-rootfs | pad-rootfs | senao-factory-image ens202ext
   IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
 endef
 TARGET_DEVICES += ens202ext