build: fix kmod package build on non-GNU systems
authorFelix Fietkau <nbd@nbd.name>
Mon, 29 May 2017 12:26:36 +0000 (14:26 +0200)
committerFelix Fietkau <nbd@nbd.name>
Mon, 29 May 2017 12:27:08 +0000 (14:27 +0200)
BSD paste requires a filename argument, and it accepts - to use stdin as
intended.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/kernel.mk

index 301f24be3e06606b6cc6010156acb7bee46194ac..9c01d5f2c8a211ed5a15a7d71d19ee112754f357 100644 (file)
@@ -133,7 +133,7 @@ define ModuleAutoLoad
        }; \
        $(3) \
        if [ -n "$$$$$$$$modules" ]; then \
-               modules="$$$$$$$$(echo "$$$$$$$$modules" | tr ' ' '\n' | sort | uniq | paste -s -d' ')"; \
+               modules="$$$$$$$$(echo "$$$$$$$$modules" | tr ' ' '\n' | sort | uniq | paste -s -d' ' -)"; \
                mkdir -p $(2)/etc/modules.d; \
                mkdir -p $(2)/CONTROL; \
                echo "#!/bin/sh" > $(2)/CONTROL/postinst-pkg; \