kernel: Update kernel 4.4 to 4.4.100
authorRosen Penev <rosenp@gmail.com>
Thu, 23 Nov 2017 21:42:13 +0000 (13:42 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 25 Nov 2017 18:48:39 +0000 (19:48 +0100)
Run-tested on ramips

Signed-off-by: Rosen Penev <rosenp@gmail.com>
15 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch
target/linux/gemini/patches-4.4/150-gemini-pata.patch
target/linux/generic/pending-4.4/093-MIPS-store-the-appended-dtb-address-in-a-variable.patch
target/linux/generic/pending-4.4/214-spidev_h_portability.patch
target/linux/generic/pending-4.4/630-packet_socket_type.patch
target/linux/generic/pending-4.4/701-phy_extension.patch
target/linux/generic/pending-4.4/702-phy_add_aneg_done_function.patch
target/linux/generic/pending-4.4/703-phy-add-detach-callback-to-struct-phy_driver.patch
target/linux/generic/pending-4.4/710-phy-add-mdio_register_board_info.patch
target/linux/generic/pending-4.4/902-debloat_proc.patch
target/linux/mvebu/patches-4.4/125-phy-provide-a-hook-for-link-up-link-down-events.patch
target/linux/mvebu/patches-4.4/128-phy-export-phy_speed_to_str-for-phylink.patch
target/linux/mvebu/patches-4.4/130-phylink-add-phylink-infrastructure.patch
target/linux/oxnas/patches-4.4/500-oxnas-sata.patch

index 55010add294db2eaa9f4b18fe2ad986d24867fb5..8fb560ec49bcecb3940ae59bcf91f0e58fdfbfeb 100644 (file)
@@ -3,11 +3,11 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .71
-LINUX_VERSION-4.4 = .93
+LINUX_VERSION-4.4 = .100
 LINUX_VERSION-4.9 = .65
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
-LINUX_KERNEL_HASH-4.4.93 = ed349314f16e78a6571b5f8884f6452782aef6c26b81bcc7ccdac44ecd917c36
+LINUX_KERNEL_HASH-4.4.100 = 9936cd99c4bd35f6bc6962c9acdd1fa2ac8999e07a9be6a94a03b5492f1bd14f
 LINUX_KERNEL_HASH-4.9.65 = 24ba70877549a3cf25dc5f12efd260d3e957bce64c087de98baf8968ee514895
 
 ifdef KERNEL_PATCHVER
index 5bedf5dc9effc53c96a8ace4ac393b49315ffe9c..8789b644a66c850c0b1c26704564953796f22cc7 100644 (file)
  
        t = ip6gre_tunnel_lookup(skb->dev, &ipv6h->daddr, &ipv6h->saddr,
                                 key, greh->protocol);
-@@ -479,11 +479,11 @@ static int ip6gre_rcv(struct sk_buff *sk
+@@ -482,11 +482,11 @@ static int ip6gre_rcv(struct sk_buff *sk
                        offset += 4;
                }
                if (flags&GRE_KEY) {
                        offset += 4;
                }
        }
-@@ -745,7 +745,7 @@ static netdev_tx_t ip6gre_xmit2(struct s
+@@ -748,7 +748,7 @@ static netdev_tx_t ip6gre_xmit2(struct s
  
                if (tunnel->parms.o_flags&GRE_SEQ) {
                        ++tunnel->o_seqno;
                        ptr--;
                }
                if (tunnel->parms.o_flags&GRE_KEY) {
-@@ -841,7 +841,7 @@ static inline int ip6gre_xmit_ipv6(struc
+@@ -844,7 +844,7 @@ static inline int ip6gre_xmit_ipv6(struc
  
        dsfield = ipv6_get_dsfield(ipv6h);
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_TCLASS)
index 3da05c5193512f98b631c7fe22929fbfea506500..1054be08b5a4f4d01486449d8e62c05ffebfd0af 100644 (file)
                .length         = SZ_512K,
 --- a/drivers/ata/Kconfig
 +++ b/drivers/ata/Kconfig
-@@ -564,6 +564,16 @@ config PATA_EP93XX
+@@ -567,6 +567,16 @@ config PATA_EP93XX
  
          If unsure, say N.
  
index 764c1cb830cbfbd7432517654191b92e55364d23..d868d210aae9446b7694c96bc05924596483f583 100644 (file)
@@ -119,7 +119,7 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
        /* Set the SP after an empty pt_regs.  */
 --- a/arch/mips/kernel/setup.c
 +++ b/arch/mips/kernel/setup.c
-@@ -814,6 +814,10 @@ void __init setup_arch(char **cmdline_p)
+@@ -886,6 +886,10 @@ void __init setup_arch(char **cmdline_p)
  unsigned long kernelsp[NR_CPUS];
  unsigned long fw_arg0, fw_arg1, fw_arg2, fw_arg3;
  
index dbee0905473d97c7d09b028767f2f4a72da79d58..39fa32ffa273f9b7856dadbd6ed985c5b6c2ddf5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/uapi/linux/spi/spidev.h
 +++ b/include/uapi/linux/spi/spidev.h
-@@ -111,7 +111,7 @@ struct spi_ioc_transfer {
+@@ -112,7 +112,7 @@ struct spi_ioc_transfer {
  
  /* not all platforms use <asm-generic/ioctl.h> or _IOC_TYPECHECK() ... */
  #define SPI_MSGSIZE(N) \
index 8c6b7a37b575ab6811525a15ccb590b328af35fb..a427165f410272055b43a46fc6c9b5f448c0b304 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #define PACKET_FANOUT_LB              1
 --- a/net/packet/af_packet.c
 +++ b/net/packet/af_packet.c
-@@ -1776,6 +1776,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1784,6 +1784,7 @@ static int packet_rcv_spkt(struct sk_buf
  {
        struct sock *sk;
        struct sockaddr_pkt *spkt;
@@ -34,7 +34,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        /*
         *      When we registered the protocol we saved the socket in the data
-@@ -1783,6 +1784,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1791,6 +1792,7 @@ static int packet_rcv_spkt(struct sk_buf
         */
  
        sk = pt->af_packet_priv;
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        /*
         *      Yank back the headers [hope the device set this
-@@ -1795,7 +1797,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1803,7 +1805,7 @@ static int packet_rcv_spkt(struct sk_buf
         *      so that this procedure is noop.
         */
  
@@ -51,7 +51,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                goto out;
  
        if (!net_eq(dev_net(dev), sock_net(sk)))
-@@ -1998,12 +2000,12 @@ static int packet_rcv(struct sk_buff *sk
+@@ -2006,12 +2008,12 @@ static int packet_rcv(struct sk_buff *sk
        int skb_len = skb->len;
        unsigned int snaplen, res;
  
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -2123,12 +2125,12 @@ static int tpacket_rcv(struct sk_buff *s
+@@ -2131,12 +2133,12 @@ static int tpacket_rcv(struct sk_buff *s
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h2)) != 32);
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h3)) != 48);
  
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3115,6 +3117,7 @@ static int packet_create(struct net *net
+@@ -3127,6 +3129,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3744,6 +3747,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3756,6 +3759,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3796,6 +3809,13 @@ static int packet_getsockopt(struct sock
+@@ -3809,6 +3822,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index a1c48b7a3a4a901f4d0daa6e695d390134a5c02b..6cb3fdfd4431674ca4f816a5e113fa1b60cf3a7f 100644 (file)
@@ -53,7 +53,7 @@
   * @phydev: the phy_device struct
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -800,6 +800,7 @@ void phy_start_machine(struct phy_device
+@@ -796,6 +796,7 @@ void phy_start_machine(struct phy_device
  void phy_stop_machine(struct phy_device *phydev);
  int phy_ethtool_sset(struct phy_device *phydev, struct ethtool_cmd *cmd);
  int phy_ethtool_gset(struct phy_device *phydev, struct ethtool_cmd *cmd);
index 39ac22f1adf79e5b2df88313a9f09cb8b7126b16..f20f48f40516ac2c3015489e5c95938ffa6e705a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -501,6 +501,12 @@ struct phy_driver {
+@@ -497,6 +497,12 @@ struct phy_driver {
        /* Determines the negotiated speed and duplex */
        int (*read_status)(struct phy_device *phydev);
  
index 5babfdf5e2f6b6598a306c30cb4be8bc2a80316d..4ef3b781fafdf588a68ca1393787c08ffbe2abee 100644 (file)
@@ -12,7 +12,7 @@
        phy_suspend(phydev);
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -519,6 +519,12 @@ struct phy_driver {
+@@ -515,6 +515,12 @@ struct phy_driver {
         */
        int (*did_interrupt)(struct phy_device *phydev);
  
index bd15df23841aded61e8650a879e4ebe26519f0c4..4886dd0e3aa7e023ab97103a877867bc63053612 100644 (file)
@@ -46,7 +46,7 @@
                phy_device_free(phydev);
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -839,6 +839,23 @@ void mdio_bus_exit(void);
+@@ -835,6 +835,23 @@ void mdio_bus_exit(void);
  
  extern struct bus_type mdio_bus_type;
  
index 98e78183deebda3c8e2cad90c2ee66b6b43a2ed6..1ef9f9800cf83f8227aad537794f28c359a0c681 100644 (file)
                goto err;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -3042,6 +3042,8 @@ static __net_initdata struct pernet_oper
+@@ -3044,6 +3044,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {
index a27e6baec3dd91fbd1f29b7b3023a4cb4bb6bcc5..0a0157be9d2e694246ce193c8be0146ff2de8166 100644 (file)
@@ -173,7 +173,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
  
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -433,6 +433,7 @@ struct phy_device {
+@@ -429,6 +429,7 @@ struct phy_device {
  
        u8 mdix;
  
index 1b79259dac8cc31c4b665eb49f0e1446fc47a2c8..c43607029c01aedfaca5ed6dc9769bdc0dd1ab5b 100644 (file)
@@ -34,7 +34,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
        case PHY_##_state:                      \
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -816,6 +816,7 @@ int phy_ethtool_gset(struct phy_device *
+@@ -812,6 +812,7 @@ int phy_ethtool_gset(struct phy_device *
  int phy_ethtool_ioctl(struct phy_device *phydev, void *useraddr);
  int phy_mii_ioctl(struct phy_device *phydev, struct ifreq *ifr, int cmd);
  int phy_start_interrupts(struct phy_device *phydev);
index 0d340c8278fdb341e65682da98291297b69207e9..141ea07d2a5c2d3055d27c6ed167bc140150dc7d 100644 (file)
@@ -914,7 +914,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
 +MODULE_LICENSE("GPL");
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -147,6 +147,7 @@ static inline const char *phy_modes(phy_
+@@ -143,6 +143,7 @@ static inline const char *phy_modes(phy_
  #define MII_ADDR_C45 (1<<30)
  
  struct device;
@@ -922,7 +922,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
  struct sk_buff;
  
  /*
-@@ -429,6 +430,7 @@ struct phy_device {
+@@ -425,6 +426,7 @@ struct phy_device {
  
        struct mutex lock;
  
index 3891dc1bc262bb8253667d4a1dc9392783825272..b833b635aa9cc3c1d946137be0ce357fbef0c51f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/ata/Kconfig
 +++ b/drivers/ata/Kconfig
-@@ -429,6 +429,13 @@ config SATA_VITESSE
+@@ -432,6 +432,13 @@ config SATA_VITESSE
  
          If unsure, say N.