ramips: add support for ZBT WE3526
authorFelix Fietkau <nbd@nbd.name>
Tue, 7 Nov 2017 12:17:06 +0000 (13:17 +0100)
committerFelix Fietkau <nbd@nbd.name>
Thu, 16 Nov 2017 11:52:55 +0000 (12:52 +0100)
This is a variant of the ZBT WG3526 with a few minor modifications.
The wifi chips are swapped, and there is no GPIO controllable status
LED. There is also no SATA port.

Specifications:

- MT7621AT (880 MHz)
- 512 MB RAM
- 16 MB Flash (SPI NOR)
- 5x 1Gbps Ethernet (built-in switch)
- MT7612E 802.11ac 5 GHz WLAN
- MT7603E 802.11n 2.4 GHz WLAN

Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/ZBT-WE3526.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk

index ba9ab1567045004f0654f374855777f59ff7ac12..6ad64e6727791377ff35c712a1836b41558a378d 100755 (executable)
@@ -114,6 +114,7 @@ ramips_setup_interfaces()
        youku-yk1|\
        zbt-ape522ii|\
        zbt-we1326|\
+       zbt-we3526|\
        zbt-we826-16M|\
        zbt-we826-32M|\
        zbt-wg2626|\
index fb5e600f35ded8c5dfa9450c857abf900daec851..0d5b6bb4fcc8884a939e287030e8f697f34fc493 100755 (executable)
@@ -202,6 +202,7 @@ platform_check_image() {
        zbt-wa05|\
        zbt-we1326|\
        zbt-we2026|\
+       zbt-we3526|\
        zbt-we826-16M|\
        zbt-we826-32M|\
        zbt-wg2626|\
diff --git a/target/linux/ramips/dts/ZBT-WE3526.dts b/target/linux/ramips/dts/ZBT-WE3526.dts
new file mode 100644 (file)
index 0000000..dc7896f
--- /dev/null
@@ -0,0 +1,117 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "zbtlink,zbt-we3526", "mediatek,mt7621-soc";
+       model = "ZBT-WE3526";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x1c000000>, <0x20000000 0x4000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       palmbus: palmbus@1E000000 {
+               i2c@900 {
+                       status = "okay";
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&sdhci {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+               m25p,chunked-io = <32>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               firmware: partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0xfb0000>;
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+
+       pcie0 {
+               wifi@14c3,7662 {
+                       compatible = "pci14c3,7662";
+                       reg = <0x0000 0 0 0 0>;
+                       mediatek,mtd-eeprom = <&factory 0x8000>;
+                       ieee80211-freq-limit = <5000000 6000000>;
+
+                       led {
+                               led-sources = <2>;
+                       };
+               };
+       };
+
+       pcie1 {
+               wifi@14c3,7603 {
+                       compatible = "pci14c3,7603";
+                       reg = <0x0000 0 0 0 0>;
+                       mediatek,mtd-eeprom = <&factory 0x0000>;
+               };
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xe000>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "wdt";
+                       ralink,function = "gpio";
+               };
+       };
+};
index 1dc5b1df3d7e1dc61848168e247f9d0b14b81829..82d0eeae62e10aaa3bfa4a9815b2d7883d94a107 100644 (file)
@@ -329,6 +329,17 @@ define Device/zbt-we1326
 endef
 TARGET_DEVICES += zbt-we1326
 
+define Device/zbt-we3526
+  DTS := ZBT-WE3526
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  SUPPORTED_DEVICES += zbt-we3526
+  DEVICE_TITLE := ZBT WE3526
+  DEVICE_PACKAGES := \
+       kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 \
+       kmod-usb3 kmod-usb-ledtrig-usbport wpad-mini
+endef
+TARGET_DEVICES += zbt-we3526
+
 define Device/zbt-wg2626
   DTS := ZBT-WG2626
   IMAGE_SIZE := $(ralink_default_fw_size_16M)