uboot-omap: Update to u-boot v2017.01
authorAlexandru Gagniuc <alex.g@adaptrum.com>
Wed, 1 Feb 2017 19:21:24 +0000 (11:21 -0800)
committerJohn Crispin <john@phrozen.org>
Mon, 20 Feb 2017 08:12:04 +0000 (09:12 +0100)
Specifying USE_PRIVATE_LIBGCC is no longer needed, as it is the
default.

Patch 001 is removed, since it was already merged upstream. Patches
100 and 101 are removed because they do not appear to be needed
anymore, and they do not conform with the sign-off and commit message
procedures.

Signed-off-by: Alexandru Gagniuc <alex.g@adaptrum.com>
package/boot/uboot-omap/Makefile
package/boot/uboot-omap/patches/001-backport_upstream_image_c_fix_non_android_booting.patch [deleted file]
package/boot/uboot-omap/patches/100-disable_thumb_unknown_errata.patch [deleted file]
package/boot/uboot-omap/patches/101-disable_ext.patch [deleted file]

index 1b73f1c9f0455c801c2a5fe646cfde169215e958..35a76c8ef20575f7d88f1d9c9912a5436c85add4 100644 (file)
@@ -7,10 +7,10 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=2015.10
+PKG_VERSION:=2017.01
 PKG_RELEASE:=1
 
-PKG_HASH:=bdc68d5f9455ad933b059c735d983f2c8b6b552dafb062e5ff1444f623021955
+PKG_HASH:=6c425175f93a4bcf2ec9faf5658ef279633dbd7856a293d95bd1ff516528ecf2
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
@@ -38,6 +38,5 @@ define U-Boot/omap3_beagle
 endef
 
 UBOOT_TARGETS:=omap4_panda am335x_evm omap3_overo omap3_beagle
-UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
 
 $(eval $(call BuildPackage/U-Boot))
diff --git a/package/boot/uboot-omap/patches/001-backport_upstream_image_c_fix_non_android_booting.patch b/package/boot/uboot-omap/patches/001-backport_upstream_image_c_fix_non_android_booting.patch
deleted file mode 100644 (file)
index b8e65b5..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From c139b5ff0999ec3d44a02ebdb623a92e5782e53e Mon Sep 17 00:00:00 2001
-From: Tom Rini <trini@konsulko.com>
-Date: Tue, 27 Oct 2015 19:04:40 -0400
-Subject: [PATCH] image.c: Fix non-Android booting with ramdisk and/or device
- tree
-
-In 1fec3c5 I added a check that if we had an Android image we default to
-trying the kernel address for a ramdisk.  However when we don't have an
-Android image buf is NULL and we oops here.  Ensure that we have 'buf'
-to check first.
-
-Reported-by: elipe Balbi <balbi@ti.com>
-Signed-off-by: Tom Rini <trini@konsulko.com>
----
- common/image.c |    2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/common/image.c b/common/image.c
-index e607109..85c4f39 100644
---- a/common/image.c
-+++ b/common/image.c
-@@ -913,7 +913,7 @@ int boot_get_ramdisk(int argc, char * const argv[], bootm_headers_t *images,
-        * Look for an Android boot image.
-        */
-       buf = map_sysmem(images->os.start, 0);
--      if (genimg_get_format(buf) == IMAGE_FORMAT_ANDROID)
-+      if (buf && genimg_get_format(buf) == IMAGE_FORMAT_ANDROID)
-               select = argv[0];
- #endif
--- 
-1.7.10.4
-
diff --git a/package/boot/uboot-omap/patches/100-disable_thumb_unknown_errata.patch b/package/boot/uboot-omap/patches/100-disable_thumb_unknown_errata.patch
deleted file mode 100644 (file)
index 7b7bfa8..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/include/configs/ti_armv7_common.h
-+++ b/include/configs/ti_armv7_common.h
-@@ -233,8 +233,6 @@
- #define CONFIG_SPL_EXT_SUPPORT
- #endif
--#define CONFIG_SYS_THUMB_BUILD
--
- /* General parts of the framework, required. */
- #define CONFIG_SPL_I2C_SUPPORT
- #define CONFIG_SPL_LIBCOMMON_SUPPORT
diff --git a/package/boot/uboot-omap/patches/101-disable_ext.patch b/package/boot/uboot-omap/patches/101-disable_ext.patch
deleted file mode 100644 (file)
index 9e0e47c..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/include/configs/ti_armv7_common.h
-+++ b/include/configs/ti_armv7_common.h
-@@ -230,7 +230,6 @@
- #define CONFIG_SPL_LIBDISK_SUPPORT
- #define CONFIG_SPL_MMC_SUPPORT
- #define CONFIG_SPL_FAT_SUPPORT
--#define CONFIG_SPL_EXT_SUPPORT
- #endif
- /* General parts of the framework, required. */