ramips: fix DCH-M225 support
authorMathias Kresin <dev@kresin.me>
Sat, 18 Nov 2017 10:59:22 +0000 (11:59 +0100)
committerMathias Kresin <dev@kresin.me>
Wed, 22 Nov 2017 07:21:52 +0000 (08:21 +0100)
Setting the pins of the UARTF group to GPIO+I2S at the time the I2C
driver loads is to late for the wps GPIO button.

The gpio-keys driver fails to load since the pin used by the wps button
is not yet set to GPIO. The wps button with the rfkill keycode is
essential for this wireless only board.

Add the missing sound and I2C kernel modules corresponding to the
device nodes.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/dts/DCH-M225.dts
target/linux/ramips/image/mt7620.mk

index 867335e95720370a9f6246bb86ca933f60e1c877..5856036c954b634c36aa0a232131b82ca7f9ea68 100644 (file)
@@ -90,7 +90,7 @@
        #sound-dai-cells = <0>;
        status = "okay";
        pinctrl-names = "default";
-       pinctrl-0 = <&gpio_i2s_pins>, <&wm8960_mclk_pins>;
+       pinctrl-0 = <&wm8960_mclk_pins>;
 };
 
 &spi0 {
                        ralink,function = "gpio";
                };
 
+               gpio_i2s {
+                       ralink,group = "uartf";
+                       ralink,function = "gpio i2s";
+               };
+
                pa {
                        ralink,group = "pa";
                        ralink,function = "pa";
index 796cc619a3a673be6f8b7eb6ab6726287dc13368..ab03cf1e1681dcf40f4e2b7b5971fafb96ca23e3 100644 (file)
@@ -139,7 +139,7 @@ define Device/dch-m225
        seama-seal -m "signature=wapn22_dlink.2013gui_dap1320b" | \
        check-size $$$$(IMAGE_SIZE)
   DEVICE_TITLE := D-Link DCH-M225
-  DEVICE_PACKAGES := kmod-mt76
+  DEVICE_PACKAGES := kmod-mt76 kmod-sound-core kmod-sound-mt7620 kmod-i2c-ralink
 endef
 TARGET_DEVICES += dch-m225