ar71xx: add metadata to wpj344 and wpj558 images
authorEnrique Giraldo <enrique.giraldo@galgus.net>
Wed, 2 Aug 2017 15:08:32 +0000 (17:08 +0200)
committerPiotr Dymacz <pepe2k@gmail.com>
Sun, 10 Sep 2017 20:15:04 +0000 (22:15 +0200)
This adds metadata to wpj344 and wpj558 images to prevent loading
firmware of wpj344 into wpj558 and vice versa. This until now was
possible and break the units and had to be recovered from the uboot.

Signed-off-by: Enrique Giraldo <enrique.giraldo@galgus.net>
target/linux/ar71xx/image/generic.mk

index 726b03a04c212c8731df74107fee863e22e40fdf..3352d156ac55a0e3def82bc400af33864ab05428 100644 (file)
@@ -874,6 +874,9 @@ define Device/wpj344
   $(Device/wpj-16m)
   DEVICE_TITLE := Compex WPJ344 (16MB flash)
   BOARDNAME := WPJ344
+  SUPPORTED_DEVICES := wpj344
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
 endef
 
 define Device/wpj531
@@ -886,6 +889,9 @@ define Device/wpj558
   $(Device/wpj-16m)
   DEVICE_TITLE := Compex WPJ558 (16MB flash)
   BOARDNAME := WPJ558
+  SUPPORTED_DEVICES := wpj558
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
 endef
 
 define Device/wpj563