kernel: move initramfs's init script out of base-files
authorRafał Miłecki <rafal@milecki.pl>
Mon, 27 Mar 2017 09:03:01 +0000 (11:03 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Tue, 4 Apr 2017 12:06:40 +0000 (14:06 +0200)
Keeping it in base-files was resulting in adding it to the base-files
package. This file is meant to be included manually for initramfs
images only.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
include/kernel-defaults.mk
target/linux/generic/base-files/init [deleted file]
target/linux/generic/other-files/init [new file with mode: 0755]

index 9fa5c1d3dd9698e7285ff3149cd8e5675647a4b0..407c1924a152e8b87bcb402098b8ed0c4b30ac6b 100644 (file)
@@ -167,7 +167,7 @@ endef
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
 define Kernel/CompileImage/Initramfs
        $(call Kernel/Configure/Initramfs)
-       $(CP) $(GENERIC_PLATFORM_DIR)/base-files/init $(TARGET_DIR)/init
+       $(CP) $(GENERIC_PLATFORM_DIR)/other-files/init $(TARGET_DIR)/init
        rm -rf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/usr/initramfs_data.cpio*
        +$(MAKE) $(KERNEL_MAKEOPTS) $(if $(KERNELNAME),$(KERNELNAME),all) modules
        $(call Kernel/CopyImage,-initramfs)
diff --git a/target/linux/generic/base-files/init b/target/linux/generic/base-files/init
deleted file mode 100755 (executable)
index 514be57..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-# Copyright (C) 2006 OpenWrt.org
-export INITRAMFS=1
-exec /sbin/init
diff --git a/target/linux/generic/other-files/init b/target/linux/generic/other-files/init
new file mode 100755 (executable)
index 0000000..514be57
--- /dev/null
@@ -0,0 +1,4 @@
+#!/bin/sh
+# Copyright (C) 2006 OpenWrt.org
+export INITRAMFS=1
+exec /sbin/init