generic: 6.6: replace Aquantia pending LEDs patch with upstream version
[openwrt/openwrt.git] / tools / missing-macros / Makefile
index 779dbfa7f3d09393524603cc35b07398fe7f03bd..15a1cc9b97d4f7a9ac2d32db90eafe2ef58202c2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=missing-macros
-PKG_VERSION:=1
+PKG_RELEASE:=12
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -20,7 +20,14 @@ endef
 
 define Host/Install
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
-       $(INSTALL_DATA) ./src/m4/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
+       $(INSTALL_DATA) $(HOST_BUILD_DIR)/m4/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/* $(STAGING_DIR_HOST)/bin/
+       $(LN) makeinfo $(STAGING_DIR_HOST)/bin/texi2any
+       $(LN) makeinfo $(STAGING_DIR_HOST)/bin/texi2pdf
+       $(LN) makeinfo $(STAGING_DIR_HOST)/bin/texi2dvi
+       $(LN) makeinfo $(STAGING_DIR_HOST)/bin/pdftexi2dvi
+       $(LN) makeinfo $(STAGING_DIR_HOST)/bin/texi2html
 endef
 
 $(eval $(call HostBuild))