generic: 6.1, 6.6: remove patch which breaks WAN on MT7621
[openwrt/openwrt.git] / include / verbose.mk
index fed83d6fb6f69081081c40daf0f1d8fb555ed6e6..f6aa0d701213907f8493afa408d723a246a7686c 100644 (file)
@@ -1,33 +1,47 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id:$
+# Copyright (C) 2006-2020 OpenWrt.org
 
-ifeq ($(NO_TRACE_MAKE),)
-NO_TRACE_MAKE := $(MAKE) V=99
-SUBMAKE := $(MAKE)
-export NO_TRACE_MAKE
-export SUBMAKE
+ifndef OPENWRT_VERBOSE
+  OPENWRT_VERBOSE:=
+endif
+ifeq ("$(origin V)", "command line")
+  OPENWRT_VERBOSE:=$(V)
 endif
 
-ifndef KBUILD_VERBOSE
-  KBUILD_VERBOSE:=0
+ifeq ($(OPENWRT_VERBOSE),1)
+  OPENWRT_VERBOSE:=w
 endif
-ifeq ("$(origin V)", "command line")
-  KBUILD_VERBOSE:=$(V)
+ifeq ($(OPENWRT_VERBOSE),99)
+  OPENWRT_VERBOSE:=s
+endif
+
+ifeq ($(NO_TRACE_MAKE),)
+NO_TRACE_MAKE := $(MAKE) V=s$(OPENWRT_VERBOSE)
+export NO_TRACE_MAKE
 endif
 
 ifeq ($(IS_TTY),1)
-  _Y:=\\033[33m
-  _N:=\\033[m
+  ifneq ($(strip $(NO_COLOR)),1)
+    _Y:=\\033[33m
+    _R:=\\033[31m
+    _N:=\\033[m
+  endif
 endif
 
-ifneq ($(KBUILD_VERBOSE),99)
+define ERROR_MESSAGE
+  { \
+       printf "$(_R)%s$(_N)\n" "$(1)" >&9 || \
+       printf "$(_R)%s$(_N)\n" "$(1)"; \
+  } >&2 2>/dev/null
+endef
+
+ifeq ($(findstring s,$(OPENWRT_VERBOSE)),)
   define MESSAGE
-       printf "$(_Y)%s$(_N)\n" "$(1)" >&3
+       { \
+               printf "$(_Y)%s$(_N)\n" "$(1)" >&8 || \
+               printf "$(_Y)%s$(_N)\n" "$(1)"; \
+       } 2>/dev/null
   endef
 
   ifeq ($(QUIET),1)
@@ -36,19 +50,22 @@ ifneq ($(KBUILD_VERBOSE),99)
     else
       _DIR:=
     endif
-    _NULL:=$(if $(MAKECMDGOALS),$(shell \
+    _MESSAGE:=$(if $(MAKECMDGOALS),$(shell \
                $(call MESSAGE, make[$(MAKELEVEL)]$(if $(_DIR), -C $(_DIR)) $(MAKECMDGOALS)); \
     ))
-  else
-    ifeq ($(KBUILD_VERBOSE),0)
-      MAKE:=>/dev/null 2>&1 $(MAKE)
+    ifneq ($(strip $(_MESSAGE)),)
+      $(info $(_MESSAGE))
     endif
+    SUBMAKE=$(MAKE)
+  else
+    SILENT:=>/dev/null $(if $(findstring w,$(OPENWRT_VERBOSE)),,2>&1)
     export QUIET:=1
-    MAKE:=cmd() { $(MAKE) -s $$* || {  echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
+    SUBMAKE=cmd() { $(SILENT) $(MAKE) -s "$$@" < /dev/null || { echo "make $$*: build failed. Please re-run make with -j1 V=s or V=sc for a higher verbosity level to see what's going on"; false; } } 8>&1 9>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)
 else
+  SUBMAKE=$(MAKE) -w
   define MESSAGE
     printf "%s\n" "$(1)"
   endef