uboot-mvebu: backport patch for Turris Omnia to enable LTO
[openwrt/openwrt.git] / package / devel / binutils / Makefile
index 09710d4b9ef03a66519f6ad58ccbef7a760420d4..3fb281c2edd3b51c702335b5ca30dcbcb94f3f11 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=binutils
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=binutils
-PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
-#"))
-PKG_RELEASE:=5
+PKG_VERSION:=2.42
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=@GNU/binutils
 
 PKG_SOURCE_URL:=@GNU/binutils
-PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_VERSION:=$(PKG_VERSION)
+PKG_HASH:=f6e4d41fd5fc778b06b7891457b3620da5ecea1006c6a4a41ae998109f85a800
 
 
-PATCH_DIR:=$(TOPDIR)/toolchain/binutils/patches/$(PKG_VERSION)
-
-PKG_FIXUP:=autoreconf
-PKG_LIBTOOL_PATHS:=. gas bfd opcodes gprof binutils ld libiberty gold intl
+PKG_FIXUP:=patch-libtool
+PKG_LIBTOOL_PATHS:=. gas bfd opcodes gprof gprofng binutils ld libiberty gold intl libctf libsframe
 PKG_REMOVE_FILES:=libtool.m4
 PKG_INSTALL:=1
 
 PKG_REMOVE_FILES:=libtool.m4
 PKG_INSTALL:=1
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
-
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=GPL-3.0+
+PKG_CPE_ID:=cpe:/a:gnu:binutils
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_PARALLEL:=1
+PKG_BUILD_FLAGS:=no-mips16
 
 
+include $(INCLUDE_DIR)/nls.mk
 include $(INCLUDE_DIR)/package.mk
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/libbfd
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=libbfd
+  DEPENDS:=+zlib $(INTL_DEPENDS)
+endef
+
+define Package/libctf
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=libctf
+  DEPENDS:=+libbfd
+endef
+
+define Package/libopcodes
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=libopcodes
+  DEPENDS:=+libbfd
+endef
+
 define Package/binutils
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=binutils
 define Package/binutils
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=binutils
-  DEPENDS:=+objdump
+  DEPENDS:=+objdump +ar
+  ALTERNATIVES:=200:/usr/bin/strings:/usr/bin/binutils-strings
 endef
 
 define Package/objdump
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=objdump
 endef
 
 define Package/objdump
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=objdump
-  DEPENDS:=+zlib 
+  DEPENDS:=+libopcodes +libctf
+endef
+
+define Package/ar
+  SECTION:=devel
+  CATEGORY:=Development
+  TITLE:=ar
+  DEPENDS:=+zlib +libbfd
 endef
 
 define Package/binutils/description
   The Binutils package contains a linker, an assembler, and other tools for handling object files
 endef
 
 endef
 
 define Package/binutils/description
   The Binutils package contains a linker, an assembler, and other tools for handling object files
 endef
 
-CONFIGURE_ARGS = \
-               --target=$(REAL_GNU_TARGET_NAME) \
-               --host=$(REAL_GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --prefix=/usr \
-               --disable-multilib \
-               --disable-werror \
-               --disable-nls \
-               --enable-shared \
-               $(SOFT_FLOAT_CONFIG_OPTION) \
-               $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS))
-
-TARGET_CFLAGS += $(FPIC)
-TARGET_LDFLAGS := -L$(PKG_BUILD_DIR)/libiberty $(TARGET_LDFLAGS)
-
-define Build/Configure
-       $(call Build/Configure/Default)
-       $(call Build/Compile/Default, \
-               configure-bfd \
-               configure-binutils \
-               configure-etc \
-               configure-gas \
-               configure-gprof \
-               configure-intl \
-               configure-ld \
-               configure-libiberty \
-               configure-opcodes \
-       )
-       $(MAKE) CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR)/bfd/po Makefile
+TARGET_CFLAGS += $(FPIC) -Wno-unused-value
+
+TARGET_LDFLAGS += $(if $(INTL_FULL),-lintl)
+
+CONFIGURE_ARGS += \
+       --host=$(REAL_GNU_TARGET_NAME) \
+       --target=$(REAL_GNU_TARGET_NAME) \
+       --enable-shared \
+       --enable-install-libiberty \
+       --enable-install-libbfd \
+       --enable-install-libctf \
+       --with-system-zlib \
+       --without-zstd \
+       --without-msgpack \
+       --disable-gprofng
+
+define Build/Install
+       $(call Build/Install/Default)
+       $(MAKE) -C $(PKG_BUILD_DIR)/libiberty \
+               target_header_dir=libiberty \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               MULTIOSDIR="" \
+               install
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/{lib,include}
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/* \
-               $(1)/usr/lib/
-       $(CP) \
-               $(PKG_BUILD_DIR)/include/*.h \
-               $(1)/usr/include/
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/include/* \
-               $(1)/usr/include/
-       rm -f $(1)/usr/include/gdbm.h
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/libbfd/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbfd*.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsframe*.so* $(1)/usr/lib/
+endef
+
+define Package/libctf/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libctf*.so* $(1)/usr/lib/
 endef
 
 endef
 
-define Build/Compile
-       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)/bfd/doc/ CFLAGS="-I$(PKG_BUILD_DIR)/include" chew
-       $(call Build/Compile/Default)
+define Package/libopcodes/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopcodes*.so $(1)/usr/lib/
 endef
 
 define Package/objdump/install
 endef
 
 define Package/objdump/install
-       $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/objdump $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/objdump $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopcodes*.so $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbfd*.so $(1)/usr/lib/
+endef
+
+define Package/ar/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ar $(1)/usr/bin/
 endef
 
 define Package/binutils/install
        $(INSTALL_DIR) $(1)/usr $(1)/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ $(1)/usr/
 endef
 
 define Package/binutils/install
        $(INSTALL_DIR) $(1)/usr $(1)/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ $(1)/usr/
-       mv $(1)/usr/bin/strings $(1)/bin/strings
+       mv $(1)/usr/bin/strings $(1)/usr/bin/binutils-strings
        rm -f $(1)/usr/bin/objdump
        rm -f $(1)/usr/bin/objdump
+       rm -f $(1)/usr/bin/ar
 endef
 
 endef
 
+$(eval $(call BuildPackage,libbfd))
+$(eval $(call BuildPackage,libctf))
+$(eval $(call BuildPackage,libopcodes))
 $(eval $(call BuildPackage,binutils))
 $(eval $(call BuildPackage,objdump))
 $(eval $(call BuildPackage,binutils))
 $(eval $(call BuildPackage,objdump))
+$(eval $(call BuildPackage,ar))