ipq40xx: fritzrepeater-1200: fix MDIO and PHY probing
[openwrt/openwrt.git] / package / devel / valgrind / Makefile
index 26dcf0b5c98cf27d68ce8db91cbdb01f945d78d6..9f8a2e9e79acb450ad7c70c0bca287104bec0faf 100644 (file)
@@ -8,19 +8,24 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=valgrind
-PKG_VERSION:=3.8.1
+PKG_VERSION:=3.22.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://valgrind.org/downloads/
-PKG_MD5SUM:=288758010b271119a0ffc0183f1d6e38
+PKG_SOURCE_URL:=https://sourceware.org/pub/valgrind/
+PKG_HASH:=c811db5add2c5f729944caf47c4e7a65dcaabb9461e472b578765dd7bf6d2d4c
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=GPL-2.0+
+PKG_CPE_ID:=cpe:/a:valgrind:valgrind
 
 PKG_FIXUP = autoreconf
 PKG_INSTALL := 1
 PKG_BUILD_PARALLEL := 1
-PKG_USE_MIPS16:=0
+PKG_BUILD_FLAGS:=no-mips16
+PKG_SSP:=0
+
+STRIP:=:
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -28,7 +33,7 @@ include $(INCLUDE_DIR)/kernel.mk
 define Package/valgrind
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:=@mips||mipsel||i386||x86_64||powerpc||arm_v7 +libpthread +librt
+  DEPENDS:=@mips||mipsel||mips64||mips64el||i386||x86_64||powerpc||arm_v7||aarch64 +libpthread +librt
   TITLE:=debugging and profiling tools for Linux
   URL:=http://www.valgrind.org
 endef
@@ -77,12 +82,12 @@ define Package/valgrind/description
        to speed up and reduce memory use of your programs.
 endef
 
-CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(LINUX_KARCH)))
+CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(patsubst um,$(ARCH),$(LINUX_KARCH))))
 
 CONFIGURE_VARS += \
        UNAME_R=$(LINUX_VERSION)
 
-ifeq ($(ARCH),x86_64)
+ifeq ($(CONFIG_ARCH_64BIT),y)
        CONFIGURE_ARGS += \
                --enable-only64bit
        BITS := 64bit
@@ -93,6 +98,7 @@ else
 endif
 
 CONFIGURE_ARGS += \
+       --enable-lto \
        --enable-tls \
        --without-x \
        --without-mpicc \
@@ -100,9 +106,10 @@ CONFIGURE_ARGS += \
        --disable-valgrindmi \
        --disable-tui \
        --disable-valgrindtk \
-       --without-included-gettext
+       --without-included-gettext \
+       --with-pagesize=4 \
 
-define Package/valgrind/install        
+define Package/valgrind/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/valgrind* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/valgrind
@@ -110,12 +117,21 @@ define Package/valgrind/install
                ./files/default.supp \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/none-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_core*.so \
-               $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(CPU)-*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(BITS)-core*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(BITS)-linux*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/memcheck-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_memcheck*.so \
                $(1)/usr/lib/valgrind/
+
+ifneq ($(ARCH),aarch64)
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(CPU)-*.xml \
+               $(1)/usr/lib/valgrind/
+endif
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip -g",$(RSTRIP)) \
+               $(PKG_INSTALL_DIR)/usr/lib/valgrind/none-* \
+               $(PKG_INSTALL_DIR)/usr/lib/valgrind/memcheck-*
 endef
 
 define Package/valgrind-cachegrind/install
@@ -125,6 +141,8 @@ define Package/valgrind-cachegrind/install
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/cachegrind-* \
                $(1)/usr/lib/valgrind/
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip -g",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/lib/valgrind/cachegrind-*
 endef
 
 define Package/valgrind-callgrind/install
@@ -134,6 +152,8 @@ define Package/valgrind-callgrind/install
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/callgrind-* \
                $(1)/usr/lib/valgrind/
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip -g",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/lib/valgrind/callgrind-*
 endef
 
 define Package/valgrind-drd/install
@@ -142,6 +162,8 @@ define Package/valgrind-drd/install
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/drd-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_drd*.so \
                $(1)/usr/lib/valgrind/
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip -g",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/lib/valgrind/drd-*
 endef
 
 define Package/valgrind-massif/install
@@ -152,6 +174,8 @@ define Package/valgrind-massif/install
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/massif-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_massif*.so \
                $(1)/usr/lib/valgrind/
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip -g",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/lib/valgrind/massif-*
 endef
 
 define Package/valgrind-helgrind/install
@@ -160,11 +184,14 @@ define Package/valgrind-helgrind/install
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/helgrind-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_helgrind*.so \
                $(1)/usr/lib/valgrind/
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip -g",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/lib/valgrind/helgrind-*
 endef
 
 define Package/valgrind-vgdb/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vgdb $(1)/usr/bin/
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
 endef
 
 $(eval $(call BuildPackage,valgrind))