qualcommax: ipq807x: add support for Linksys MX8500
[openwrt/openwrt.git] / package / libs / libnfnetlink / Makefile
index cc797e6e2d17261cd82984d78e37eb05827e76b8..be1eba6517d85231630c76d05e02ad519bfb7737 100644 (file)
@@ -8,16 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnfnetlink
-PKG_VERSION:=1.0.1
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://www.netfilter.org/projects/libnfnetlink/files/ \
        ftp://ftp.netfilter.org/pub/libnfnetlink/
-PKG_HASH:=f270e19de9127642d2a11589ef2ec97ef90a649a74f56cf9a96306b04817b51a
+PKG_HASH:=b064c7c3d426efb4786e60a8e6859b82ee2f2c5e49ffeea640cfe4fe33cbc376
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=GPL-2.0+
+PKG_CPE_ID:=cpe:/a:netfilter:libnfnetlink
 
 PKG_FIXUP:=autoreconf
 
@@ -40,12 +41,13 @@ define Package/libnfnetlink/description
  and/or management tools in userspace.
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
 CONFIGURE_ARGS += \
        --enable-static \
        --enable-shared
 
+CONFIGURE_VARS += \
+       lt_prog_compiler_pic="$(FPIC)"
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/libnfnetlink
        $(CP) \