kernel: bump 6.1 to 6.1.89
[openwrt/openwrt.git] / scripts / checkpatch.pl
index 8ffc093548885de2baede81a0471e9e74652e306..2adc5efec5e6bf1061d6b9133eca2111b0e1dec6 100755 (executable)
@@ -1113,7 +1113,7 @@ sub top_of_openwrt_tree {
        my ($root) = @_;
 
        my @tree_check = (
-               "BSDmakefile", "Config.in", "LICENSE", "Makefile", "README.md",
+               "BSDmakefile", "Config.in", "LICENSES", "Makefile", "README.md",
                "feeds.conf.default", "include", "package", "rules.mk",
                "scripts", "target", "toolchain", "tools"
        );
@@ -4697,7 +4697,7 @@ sub process {
 ##                 $line !~ /^.\s*$Type\s+$Ident(?:\s*=[^,{]*)?\s*,\s*$Type\s*$Ident.*/) {
 ##
 ##                     # Remove any bracketed sections to ensure we do not
-##                     # falsly report the parameters of functions.
+##                     # falsely report the parameters of functions.
 ##                     my $ln = $line;
 ##                     while ($ln =~ s/\([^\(\)]*\)//g) {
 ##                     }