kernel: bump 6.1 to 6.1.89
[openwrt/openwrt.git] / scripts / checkpatch.pl
index 9da28baf35361a735325cf1337126b23769fee67..2adc5efec5e6bf1061d6b9133eca2111b0e1dec6 100755 (executable)
@@ -1113,7 +1113,7 @@ sub top_of_openwrt_tree {
        my ($root) = @_;
 
        my @tree_check = (
-               "BSDmakefile", "Config.in", "LICENSE", "Makefile", "README.md",
+               "BSDmakefile", "Config.in", "LICENSES", "Makefile", "README.md",
                "feeds.conf.default", "include", "package", "rules.mk",
                "scripts", "target", "toolchain", "tools"
        );
@@ -2355,7 +2355,7 @@ sub process {
        my $commit_log_possible_stack_dump = 0;
        my $commit_log_long_line = 0;
        my $commit_log_has_diff = 0;
-       my $reported_maintainer_file = 0;
+       my $reported_maintainer_file = 1;
        my $non_utf8_charset = 0;
 
        my $last_blank_line = 0;
@@ -4697,7 +4697,7 @@ sub process {
 ##                 $line !~ /^.\s*$Type\s+$Ident(?:\s*=[^,{]*)?\s*,\s*$Type\s*$Ident.*/) {
 ##
 ##                     # Remove any bracketed sections to ensure we do not
-##                     # falsly report the parameters of functions.
+##                     # falsely report the parameters of functions.
 ##                     my $ln = $line;
 ##                     while ($ln =~ s/\([^\(\)]*\)//g) {
 ##                     }