toolchain: glibc: Update glibc 2.38 to recent HEAD
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index c9bc96769f5aa6056af403d133d129f0431a4c9e..2e166a5f373902f95aea5a2a1e1c68951e5d54c5 100644 (file)
@@ -1,19 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2007-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs jffs2
-SUBTARGETS=xway ase falcon
-
-LINUX_VERSION:=3.7.8
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+KERNEL_PATCHVER:=5.15
 
 define Target/Description
        Build firmware images for Lantiq SoC