kernel: move mv88e6xxx fix to generic backports
[openwrt/openwrt.git] / target / linux / mpc85xx / image / Makefile
index 2b8188403228c635c4a58f1df084dd8051dbf4da..d502650a321c6f92d04bffedd8b07aea87d387ce 100644 (file)
@@ -3,6 +3,12 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+DEVICE_VARS += DTB_SIZE
+
+define Build/pad-dtb
+       $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$(dir $@)/image-$(DEVICE_DTS).dtb,,--space $(DTB_SIZE))
+endef
+
 define Device/Default
   PROFILES := Default
   DEVICE_DTS := $(lastword $(subst _, ,$(1)))