kernel: move mv88e6xxx fix to generic backports
[openwrt/openwrt.git] / target / linux / mpc85xx / image / Makefile
index 618b8c71358f849cf8d75ba798202eb373e6ff0c..d502650a321c6f92d04bffedd8b07aea87d387ce 100644 (file)
@@ -1,12 +1,12 @@
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# SPDX-License-Identifier: GPL-2.0-only
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Build/copy-file
-       cat "$(1)" > "$@"
+DEVICE_VARS += DTB_SIZE
+
+define Build/pad-dtb
+       $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$(dir $@)/image-$(DEVICE_DTS).dtb,,--space $(DTB_SIZE))
 endef
 
 define Device/Default