mediatek: fix target FPU settings
authorFelix Fietkau <nbd@nbd.name>
Tue, 17 Apr 2018 11:43:06 +0000 (13:43 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 17 Apr 2018 11:46:18 +0000 (13:46 +0200)
This reverts commit 5555545494c876adedf4f0038db49c1d85527e78.
The target supports both NEON and VFPv4, but for this to work properly,
a few more changes are needed:
- enable NEON support in the kernel config
- add the fpu feature flag to the makefile

Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/mediatek/32/target.mk
target/linux/mediatek/Makefile
target/linux/mediatek/config-4.14

index 146ad95ffc06b8abd60a973900ca5df23e13651c..0a444c2758eda8d7fc7661762561749d523d65db 100644 (file)
@@ -5,6 +5,7 @@
 SUBTARGET:=32
 BOARDNAME:=32bit
 CPU_TYPE:=cortex-a7
+CPU_SUBTYPE:=neon-vfpv4
 
 define Target/Description
        Build firmware images for MediaTek 32bit ARM based boards.
index fb294ad8fb7e1cf2b1d57aef70b9745fdd0dc2cb..415fe945042841fe777c81105ae14e3d22634514 100644 (file)
@@ -6,7 +6,7 @@ ARCH:=arm
 BOARD:=mediatek
 BOARDNAME:=MediaTek Ralink ARM
 SUBTARGETS:=32
-FEATURES:=squashfs nand ubifs
+FEATURES:=squashfs nand ubifs fpu
 MAINTAINER:=John Crispin <john@phrozen.org>
 
 KERNEL_PATCHVER:=4.14
index 40977aab73caa949950bce85f42ed5c9edaa5ab2..88165045c8654b566fc1c56c75a78f3f30c531c1 100644 (file)
@@ -334,7 +334,7 @@ CONFIG_MTK_TIMER=y
 CONFIG_MULTI_IRQ_HANDLER=y
 CONFIG_MUTEX_SPIN_ON_OWNER=y
 CONFIG_NEED_DMA_MAP_STATE=y
-# CONFIG_NEON is not set
+CONFIG_NEON=y
 CONFIG_NET_DSA=y
 CONFIG_NET_DSA_MT7530=y
 CONFIG_NET_DSA_TAG_MTK=y