mediatek: mt7623: yet another legacy image variable restored
authorDaniel Golle <daniel@makrotopia.org>
Wed, 21 Jul 2021 15:18:58 +0000 (16:18 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 21 Jul 2021 15:48:35 +0000 (16:48 +0100)
Restore BOOTFS_BLOCKS variable until U7623 gets brushed, so things
hopefully build now.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mediatek/image/mt7623.mk

index 653da6b2c08d2da33d33366cf4d419e7f107c23b..9a938662c32748c97a6fe52662d56fc2156a0c9e 100644 (file)
@@ -113,6 +113,11 @@ endef
 TARGET_DEVICES += bananapi_bpi-r2
 
 
+ifneq ($(CONFIG_MTK_BOOT_PARTSIZE),)
+BOOTFS_BLOCK_SIZE := 1024
+BOOTFS_BLOCKS := $(shell echo $$(($(CONFIG_MTK_BOOT_PARTSIZE)*1024*1024/$(BOOTFS_BLOCK_SIZE))))
+endif
+
 define Build/mtk-mmc-img
        rm -f $@.boot
        mkfs.fat -C $@.boot $(BOOTFS_BLOCKS)
@@ -140,6 +145,7 @@ define Build/scatterfile
                $(subst -scatter.txt,,$(notdir $@)) "$(DEVICE_TITLE)" > $@
 endef
 
+
 # Full eMMC image including U-Boot and partition table
 define Device/unielec_u7623-emmc
   DEVICE_VENDOR := UniElec