fix timestamp checks for build system paths which have '.svn' in their directory...
authorFelix Fietkau <nbd@openwrt.org>
Wed, 14 Apr 2010 22:21:15 +0000 (22:21 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 14 Apr 2010 22:21:15 +0000 (22:21 +0000)
SVN-Revision: 20856

include/depends.mk
scripts/timestamp.pl

index 4c31eb39843de6b6e65763e93162d54bb78c2b87..65e9b25d5e564499d4bf26d6ba871fbcffca39f5 100644 (file)
@@ -11,7 +11,7 @@
 #      3: tempfile for file listings
 #      4: find options
 
 #      3: tempfile for file listings
 #      4: find options
 
-DEP_FINDPARAMS := -x "*.svn*" -x ".*" -x "*.svn*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check"
+DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check"
 
 find_md5=find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
 
 
 find_md5=find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
 
index 3bf057151f43d0725822066e7acbbd6daa721ccc..e24d8149d9c8754ba72e8918e09cd9c390427251 100755 (executable)
@@ -14,7 +14,7 @@ sub get_ts($$) {
        my $ts = 0;
        my $fn = "";
        $path .= "/" if( -d $path);
        my $ts = 0;
        my $fn = "";
        $path .= "/" if( -d $path);
-       open FIND, "find $path -type f -and -not -path \\*.svn\\* -and -not -path \\*CVS\\* $options 2>/dev/null |";
+       open FIND, "find $path -type f -and -not -path \\*/.svn\\* -and -not -path \\*CVS\\* $options 2>/dev/null |";
        while (<FIND>) {
                chomp;
                my $file = $_;
        while (<FIND>) {
                chomp;
                my $file = $_;