iproute2: update to 6.0.0
authorNick Hainke <vincent@systemli.org>
Wed, 5 Oct 2022 10:37:47 +0000 (12:37 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 22 Oct 2022 20:50:36 +0000 (22:50 +0200)
Release Notes:
https://lore.kernel.org/netdev/20221004082610.56b04719@hermes.local/t/

Remove upstreamed patch:
- 010-ipstats-Add-param.h-for-musl.patch

Refreshed:
- 140-keep_libmnl_optional.patch
- 145-keep_libelf_optional.patch
- 150-keep_libcap_optional.patch
- 155-keep_tirpc_optional.patch
- 170-ip_tiny.patch
- 190-fix-nls-rpath-link.patch
- 200-drop_libbsd_dependency.patch
- 300-selinux-configurable.patch

Signed-off-by: Nick Hainke <vincent@systemli.org>
package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/010-ipstats-Add-param.h-for-musl.patch [deleted file]
package/network/utils/iproute2/patches/140-keep_libmnl_optional.patch
package/network/utils/iproute2/patches/145-keep_libelf_optional.patch
package/network/utils/iproute2/patches/150-keep_libcap_optional.patch
package/network/utils/iproute2/patches/155-keep_tirpc_optional.patch
package/network/utils/iproute2/patches/170-ip_tiny.patch
package/network/utils/iproute2/patches/190-fix-nls-rpath-link.patch
package/network/utils/iproute2/patches/200-drop_libbsd_dependency.patch
package/network/utils/iproute2/patches/300-selinux-configurable.patch

index 52554005133b4aa5263bbd24df0b72044e3b7093..6ef0b1a96ace7ce2eba473db4dc80d8a03afd1df 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=5.19.0
+PKG_VERSION:=6.0.0
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
-PKG_HASH:=26b7a34d6a7fd2f7a42e2b39c5a90cb61bac522d1096067ffeb195e5693d7791
+PKG_HASH:=523139e9e72aec996374fa2de74be4c53d2dd05589488934d21ff97bae19580a
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=iptables
 PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/iproute2/patches/010-ipstats-Add-param.h-for-musl.patch b/package/network/utils/iproute2/patches/010-ipstats-Add-param.h-for-musl.patch
deleted file mode 100644 (file)
index d99ae6e..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-From cf6b60c504d4be5e1df2b2745e55d677967831d0 Mon Sep 17 00:00:00 2001
-From: Changhyeok Bae <changhyeok.bae@gmail.com>
-Date: Tue, 9 Aug 2022 04:01:05 +0000
-Subject: [PATCH 1/5] ipstats: Add param.h for musl
-
-Fix build error for musl
-| /usr/src/debug/iproute2/5.19.0-r0/iproute2-5.19.0/ip/ipstats.c:231: undefined reference to `MIN'
-
-Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
----
- ip/ipstats.c | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/ip/ipstats.c
-+++ b/ip/ipstats.c
-@@ -1,6 +1,7 @@
- // SPDX-License-Identifier: GPL-2.0+
- #include <assert.h>
- #include <errno.h>
-+#include <sys/param.h>
- #include "list.h"
- #include "utils.h"
index a8cdd103ba308c2178488bb9e950224741a81741..7f68f43616403588601e34ca0d1888d7336926ae 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -411,7 +411,7 @@ check_tirpc()
+@@ -412,7 +412,7 @@ check_tirpc()
  
  check_mnl()
  {
index 0c5c3f59ed9adc093be2da5001bf97f1a826fedd..2eaae88198555ffbe393e334c41986e2daf22238 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -266,7 +266,7 @@ EOF
+@@ -267,7 +267,7 @@ EOF
  
  check_elf()
  {
index 4cce2c3ca6802d44b2f74532ee6f7a835431e13b..c574840fa8ff1d63c0d0cf136631b11f259054d8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -469,7 +469,7 @@ EOF
+@@ -470,7 +470,7 @@ EOF
  
  check_cap()
  {
index 28ba7e52176d510f4b58350bf2697836f0280873..4ee6245d3b0374cc815c41997a800c990b196a6d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -398,7 +398,7 @@ check_selinux()
+@@ -399,7 +399,7 @@ check_selinux()
  
  check_tirpc()
  {
index ba2cb0637a782277547e09886cd7235ba3389076..9e95bcc2d629688b8498a8afbe34d9169dff5ca5 100644 (file)
 +
  UTILOBJ = utils.o utils_math.o rt_names.o ll_map.o ll_types.o ll_proto.o ll_addr.o \
        inet_proto.o namespace.o json_writer.o json_print.o json_print_math.o \
-       names.o color.o bpf_legacy.o bpf_glue.o exec.o fs.o cg_map.o
+       names.o color.o bpf_legacy.o bpf_glue.o exec.o fs.o cg_map.o ppp_proto.o
index c7fceb2e221063243e12e1df0b28597e4b440e3d..2f3f90fe1aafbbdfab93700ff1ee41a9330c6e21 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -290,7 +290,7 @@ int main(int argc, char **argv) {
+@@ -291,7 +291,7 @@ int main(int argc, char **argv) {
  }
  EOF
  
@@ -9,7 +9,7 @@
      local ret=$?
  
      rm -f $TMPDIR/libbpf_test.c $TMPDIR/libbpf_test
-@@ -308,7 +308,7 @@ int main(int argc, char **argv) {
+@@ -309,7 +309,7 @@ int main(int argc, char **argv) {
  }
  EOF
  
index d1948860e8665cbb2552f329e2da9e29c39b0ca5..052bdd84eb2e517c9a3fcb7417f004c08b3a45eb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -455,14 +455,8 @@ EOF
+@@ -456,14 +456,8 @@ EOF
      if $CC -I$INCLUDE -o $TMPDIR/strtest $TMPDIR/strtest.c >/dev/null 2>&1; then
        echo "no"
      else
index 817abf7d17ac0da772a79f322142d9d5bfdec1f9..adfa405c7fc11c3a052e001bfae7ada132f72a07 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -385,7 +385,7 @@ check_libbpf()
+@@ -386,7 +386,7 @@ check_libbpf()
  check_selinux()
  # SELinux is a compile time option in the ss utility
  {