ath79: add LTE packages for GL-XE300
authorTom Herbers <mail@tomherbers.de>
Sat, 10 Sep 2022 14:45:42 +0000 (16:45 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 3 Feb 2023 10:49:18 +0000 (11:49 +0100)
Add LTE packages required for operating the LTE modems shipped with
the GL-XE300.

Example configuration for an unauthenticated dual-stack APN:

network.wwan0=interface
network.wwan0.proto='qmi'
network.wwan0.device='/dev/cdc-wdm0'
network.wwan0.apn='internet'
network.wwan0.auth='none'
network.wwan0.delay='10'
network.wwan0.pdptype='IPV4V6'

Signed-off-by: Tom Herbers <mail@tomherbers.de>
(cherry picked from commit 67f283be4430ebfb46be6c00fcc7c12a6adabce3)

target/linux/ath79/image/nand.mk

index 1bf722701781e72d8d2a1ea9182af1641deb3093..0f5b07225c6e0b5d4571c453eb81fbee593769f5 100644 (file)
@@ -199,7 +199,8 @@ define Device/glinet_gl-xe300
   SOC := qca9531
   DEVICE_VENDOR := GL.iNet
   DEVICE_MODEL := GL-XE300
-  DEVICE_PACKAGES := kmod-usb2 block-mount kmod-usb-serial-ch341
+  DEVICE_PACKAGES := kmod-usb2 block-mount kmod-usb-serial-ch341 \
+       kmod-usb-net-qmi-wwan uqmi
   KERNEL_SIZE := 4096k
   IMAGE_SIZE := 131072k
   PAGESIZE := 2048