ramips: Use MT7621 I2C driver for MT7628/MT7688
authorSven Schwermer <sven.schwermer@arcor.de>
Wed, 2 Nov 2016 10:44:23 +0000 (11:44 +0100)
committerJohn Crispin <john@phrozen.org>
Thu, 3 Nov 2016 07:27:20 +0000 (08:27 +0100)
The i2c-ramips driver does not work for the MT7628/MT7688 SoCs, the
i2c-mt7621 driver does.

Signed-off-by: Sven Schwermer <sven.schwermer@arcor.de>
target/linux/ramips/modules.mk

index 70678a8376574712cfe6f7112443aae9a7e00114..99c5a9d0fcf4bc8d0f35c4f2f5a6fd0c4fb8793c 100644 (file)
@@ -47,7 +47,8 @@ I2C_RALINK_MODULES:= \
 define KernelPackage/i2c-ralink
   $(call i2c_defaults,$(I2C_RALINK_MODULES),59)
   TITLE:=Ralink I2C Controller
-  DEPENDS:=@TARGET_ramips @(!TARGET_ramips_mt7621) kmod-i2c-core
+  DEPENDS:=kmod-i2c-core @TARGET_ramips \
+       @!(TARGET_ramips_mt7621||TARGET_ramips_mt7628||TARGET_ramips_mt7688)
 endef
 
 define KernelPackage/i2c-ralink/description
@@ -63,7 +64,8 @@ I2C_MT7621_MODULES:= \
 define KernelPackage/i2c-mt7621
   $(call i2c_defaults,$(I2C_MT7621_MODULES),59)
   TITLE:=MT7621 I2C Controller
-  DEPENDS:=@TARGET_ramips @TARGET_ramips_mt7621 kmod-i2c-core
+  DEPENDS:=kmod-i2c-core \
+       @(TARGET_ramips_mt7621||TARGET_ramips_mt7628||TARGET_ramips_mt7688)
 endef
 
 define KernelPackage/i2c-mt7621/description