ath79: align GL-AR750S boardname to other GL.iNet devices
authorChristoph Krapp <achterin@googlemail.com>
Tue, 1 Jan 2019 12:03:20 +0000 (12:03 +0000)
committerMathias Kresin <dev@kresin.me>
Tue, 1 Jan 2019 18:42:41 +0000 (19:42 +0100)
As the official device name is GL-AR750S, rename the board accordingly.

Signed-off-by: Christoph Krapp <achterin@googlemail.com>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9563_glinet_ar750s.dts [deleted file]
target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index e24c58e208f8ae5e52acadf9421f8604b6c7f735..677650689358b6d452a524dea02a4c74220e9dc9 100755 (executable)
@@ -100,7 +100,7 @@ ath79_setup_interfaces()
        tplink,tl-wr810n-v2)
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
                ;;
        tplink,tl-wr810n-v2)
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
                ;;
-       glinet,ar750s)
+       glinet,gl-ar750s)
                ucidef_add_switch "switch0" \
                        "0@eth0" "2:lan:2" "3:lan:1" "1:wan"
                ;;
                ucidef_add_switch "switch0" \
                        "0@eth0" "2:lan:2" "3:lan:1" "1:wan"
                ;;
index 441893a752789508ba3b51f0bee6e5239d8df818..faee7819700f00f756107b2719949d0445e5b214 100644 (file)
@@ -99,13 +99,10 @@ case "$FIRMWARE" in
        elecom,wrc-1750ghbk2-i)
                ath10kcal_extract "ART" 20480 2116
                ;;
        elecom,wrc-1750ghbk2-i)
                ath10kcal_extract "ART" 20480 2116
                ;;
-       glinet,ar750s|\
-       tplink,re450-v2)
-               ath10kcal_extract "art" 20480 2116
-               ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
-               ;;
        engenius,ews511ap|\
        engenius,ews511ap|\
-       glinet,gl-x750)
+       glinet,gl-ar750s|\
+       glinet,gl-x750|\
+       tplink,re450-v2)
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
                ;;
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
                ;;
diff --git a/target/linux/ath79/dts/qca9563_glinet_ar750s.dts b/target/linux/ath79/dts/qca9563_glinet_ar750s.dts
deleted file mode 100644 (file)
index ab33bc1..0000000
+++ /dev/null
@@ -1,154 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "qca956x.dtsi"
-
-/ {
-       compatible = "glinet,ar750s", "qca,qca9563";
-       model = "GL.iNet GL-AR750S";
-
-       chosen {
-               bootargs = "console=ttyS0,115200n8";
-       };
-
-       aliases {
-               led-boot = &power;
-               led-failsafe = &power;
-               led-running = &power;
-               led-upgrade = &power;
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               poll-interval = <20>;
-               pinctrl-names = "default";
-               pinctrl-0 = <&jtag_disable_pins>;
-
-               reset {
-                       label = "reset";
-                       linux,code = <KEY_RESTART>;
-                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
-               };
-
-               mode {
-                       label = "mode";
-                       linux,code = <BTN_0>;
-                       linux,input-type = <EV_SW>;
-                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               power: power {
-                       label = "gl-ar750s:green:power";
-                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
-                       default-state = "keep";
-               };
-
-               wlan2g {
-                       label = "gl-ar750s:green:wlan2g";
-                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
-                       linux,default-trigger = "phy1tpt";
-               };
-
-               wlan5g {
-                       label = "gl-ar750s:green:wlan5g";
-                       gpios = <&gpio 20 GPIO_ACTIVE_HIGH>;
-                       linux,default-trigger = "phy0tpt";
-               };
-       };
-};
-
-&spi {
-       status = "okay";
-       num-cs = <0>;
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <25000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x000000 0x040000>;
-                               read-only;
-                       };
-
-                       partition@40000 {
-                               label = "u-boot-env";
-                               reg = <0x040000 0x010000>;
-                       };
-
-                       art: partition@50000 {
-                               label = "art";
-                               reg = <0x050000 0x010000>;
-                       };
-
-                       partition@60000 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x060000 0xfa0000>;
-                       };
-               };
-       };
-};
-
-&pcie {
-       status = "okay";
-};
-
-&uart {
-       status = "okay";
-};
-
-&usb0 {
-       #address-cells = <1>;
-       #size-cells = <0>;
-       status = "okay";
-
-       hub_port: port@1 {
-               reg = <1>;
-               #trigger-source-cells = <0>;
-       };
-};
-
-&usb_phy0 {
-       status = "okay";
-};
-
-&mdio0 {
-       status = "okay";
-       phy-mask = <0>;
-
-       phy0: ethernet-phy@0 {
-               reg = <0>;
-               phy-mode = "sgmii";
-               qca,ar8327-initvals = <
-                       0x04 0x00080080 /* PORT0 PAD MODE CTRL */
-                       0x7c 0x0000007e /* PORT0_STATUS */
-               >;
-       };
-};
-
-&eth0 {
-       status = "okay";
-
-       mtd-mac-address = <&art 0x0>;
-       phy-handle = <&phy0>;
-};
-
-&wmac {
-       status = "okay";
-       mtd-cal-data = <&art 0x1000>;
-       mtd-mac-address = <&art 0x1002>;
-};
diff --git a/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
new file mode 100644 (file)
index 0000000..439acaa
--- /dev/null
@@ -0,0 +1,154 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+       compatible = "glinet,gl-ar750s", "qca,qca9563";
+       model = "GL.iNet GL-AR750S";
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-boot = &power;
+               led-failsafe = &power;
+               led-running = &power;
+               led-upgrade = &power;
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <20>;
+               pinctrl-names = "default";
+               pinctrl-0 = <&jtag_disable_pins>;
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+               };
+
+               mode {
+                       label = "mode";
+                       linux,code = <BTN_0>;
+                       linux,input-type = <EV_SW>;
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               power: power {
+                       label = "gl-ar750s:green:power";
+                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+                       default-state = "keep";
+               };
+
+               wlan2g {
+                       label = "gl-ar750s:green:wlan2g";
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               wlan5g {
+                       label = "gl-ar750s:green:wlan5g";
+                       gpios = <&gpio 20 GPIO_ACTIVE_HIGH>;
+                       linux,default-trigger = "phy0tpt";
+               };
+       };
+};
+
+&spi {
+       status = "okay";
+       num-cs = <0>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                       art: partition@50000 {
+                               label = "art";
+                               reg = <0x050000 0x010000>;
+                       };
+
+                       partition@60000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x060000 0xfa0000>;
+                       };
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&uart {
+       status = "okay";
+};
+
+&usb0 {
+       #address-cells = <1>;
+       #size-cells = <0>;
+       status = "okay";
+
+       hub_port: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&usb_phy0 {
+       status = "okay";
+};
+
+&mdio0 {
+       status = "okay";
+       phy-mask = <0>;
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+               phy-mode = "sgmii";
+               qca,ar8327-initvals = <
+                       0x04 0x00080080 /* PORT0 PAD MODE CTRL */
+                       0x7c 0x0000007e /* PORT0_STATUS */
+               >;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       mtd-mac-address = <&art 0x0>;
+       phy-handle = <&phy0>;
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&art 0x1002>;
+};
index 326633835da9ccb8334f4a5eca9b21ba5dd48375..858c1662ccc62f41c336365b412d6ecfadb32aed 100644 (file)
@@ -289,14 +289,14 @@ define Device/glinet_gl-ar300m-nor
 endef
 TARGET_DEVICES += glinet_gl-ar300m-nor
 
 endef
 TARGET_DEVICES += glinet_gl-ar300m-nor
 
-define Device/glinet_ar750s
+define Device/glinet_gl-ar750s
   ATH_SOC := qca9563
   DEVICE_TITLE := GL.iNet GL-AR750S
   DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
   IMAGE_SIZE := 16000k
   SUPPORTED_DEVICES += gl-ar750s
 endef
   ATH_SOC := qca9563
   DEVICE_TITLE := GL.iNet GL-AR750S
   DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
   IMAGE_SIZE := 16000k
   SUPPORTED_DEVICES += gl-ar750s
 endef
-TARGET_DEVICES += glinet_ar750s
+TARGET_DEVICES += glinet_gl-ar750s
 
 define Device/glinet_gl-x750
   ATH_SOC := qca9531
 
 define Device/glinet_gl-x750
   ATH_SOC := qca9531