vti: use alternative way to check if kernel support is enabled
authorAlin Nastac <alin.nastac@technicolor.com>
Mon, 1 Mar 2021 08:49:43 +0000 (09:49 +0100)
committerHans Dedecker <dedeckeh@gmail.com>
Sat, 13 Mar 2021 19:59:11 +0000 (20:59 +0100)
When necessary support is built in kernel, vti protocol support is
not enabled in netifd.

Signed-off-by: Alin Nastac <alin.nastac@technicolor.com>
package/network/config/vti/Makefile
package/network/config/vti/files/vti.sh

index ffac77ab91d982de5c70dbccb74ef5879152f68d..292ab111e5c53724604c106913a5c87d1877846d 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vti
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index ebfd9d41e1466542a079f4c4d7adf26f3395e636..96b65e76d92514899fc2fa623f98e380944122f8 100755 (executable)
@@ -149,6 +149,6 @@ proto_vti6_init_config() {
 }
 
 [ -n "$INCLUDE_ONLY" ] || {
-       [ -f /lib/modules/$(uname -r)/ip_vti.ko ] && add_protocol vti
-       [ -f /lib/modules/$(uname -r)/ip6_vti.ko ] && add_protocol vti6
+       [ -d /sys/module/ip_vti ] && add_protocol vti
+       [ -d /sys/module/ip6_vti ] && add_protocol vti6
 }