ar71xx/mikrotik: use ath10k-ct-smallbuffers for 64 MiB devices
authorThomas Nixon <tom@tomn.co.uk>
Sun, 5 Jan 2020 21:38:36 +0000 (21:38 +0000)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 17 Jan 2020 23:31:37 +0000 (00:31 +0100)
This image is only needed on one device (wAP AC); since this target is
going to be removed anyway it doesn't make sense to add an extra "low
RAM" image.

Fixes OOM issues on RouterBoard wAP AC.

Signed-off-by: Thomas Nixon <tom@tomn.co.uk>
(cherry picked from commit 788c8485eb5b71ef7e7b2a2d3077772e526e9746)

target/linux/ar71xx/image/mikrotik.mk

index 23d348b6a981c78b5320cc76188a085b660bc387..19086ea423a934d2d0ad25d6cff07c15c5104ce3 100644 (file)
@@ -55,7 +55,7 @@ TARGET_DEVICES += rb-nor-flash-16M
 define Device/rb-nor-flash-16M-ac
   $(Device/rb-nor-flash-16M)
   DEVICE_TITLE := MikroTik RouterBoard (16 MB SPI NOR, 802.11ac)
-  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct ath10k-firmware-qca9887-ct kmod-usb-ehci
+  DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct ath10k-firmware-qca9887-ct kmod-usb-ehci
   SUPPORTED_DEVICES += rb-wapg-5hact2hnd
 endef
 TARGET_DEVICES += rb-nor-flash-16M-ac