samsung: use soc_vendor_model scheme for DTS file name
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 28 Dec 2019 15:04:48 +0000 (16:04 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 2 Jan 2020 23:04:05 +0000 (00:04 +0100)
This patch changes the samsung target to calculate the DTS file name
from vendor and device name and the SOC (i.e. subtarget) following
the common scheme:

soc_vendor_model.dts

This also updates the device definition name to make compatible,
image name, menuconfig name and DTS name consistent.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/samsung/dts/TQ210.dts [deleted file]
target/linux/samsung/dts/s5pv210_embedsky_tq210.dts [new file with mode: 0644]
target/linux/samsung/image/Makefile

diff --git a/target/linux/samsung/dts/TQ210.dts b/target/linux/samsung/dts/TQ210.dts
deleted file mode 100644 (file)
index d32e340..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-/*
- * Samsung's S5PV210 SoC device tree source
- * Copyright (C) 2018 Jianhui Zhao <jianhuizhao329@gmail.com>
- *
- * Board device tree source for TQ210 board.
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License version 2 as
- * published by the Free Software Foundation.
- */
-
-/dts-v1/;
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/interrupt-controller/irq.h>
-#include "s5pv210.dtsi"
-
-/ {
-       model = "Embedsky TQ210 based on S5PV210";
-       compatible = "embedsky,tq210", "samsung,s5pv210";
-
-       chosen {
-               bootargs = "console=ttySAC0,115200n8";
-       };
-
-       memory@20000000 {
-               device_type = "memory";
-               reg = <0x20000000 0x40000000>;
-       };
-
-       ethernet@88000000 {
-               compatible = "davicom,dm9000";
-               reg = <0x88000000 0x2 0x88000004 0x2>;
-               interrupt-parent = <&gph1>;
-               interrupts = <2 IRQ_TYPE_LEVEL_HIGH>;
-               local-mac-address = [00 00 de ad be ef];
-               davicom,no-eeprom;
-               clocks = <&clocks CLK_SROMC>;
-               clock-names = "sromc";
-       };
-};
-
-&xxti {
-       clock-frequency = <24000000>;
-};
-
-&uart0 {
-       status = "okay";
-};
-
-&nand {
-       status = "okay";
-       nand-ecc-mode = "soft";
-
-       partition@0 {
-               label = "boot";
-               reg = <0x0 0x40000>;            /* 246KB */
-               read-only;
-       };
-
-       partition@40000 {
-               label = "kernel";
-               reg = <0x40000 0x300000>;       /* 3MB */
-       };
-
-       partition@340000 {
-               label = "rootfs";
-               reg = <0x340000 0x3fcc0000>;    /* 1020MB */
-       };
-};
diff --git a/target/linux/samsung/dts/s5pv210_embedsky_tq210.dts b/target/linux/samsung/dts/s5pv210_embedsky_tq210.dts
new file mode 100644 (file)
index 0000000..d32e340
--- /dev/null
@@ -0,0 +1,69 @@
+/*
+ * Samsung's S5PV210 SoC device tree source
+ * Copyright (C) 2018 Jianhui Zhao <jianhuizhao329@gmail.com>
+ *
+ * Board device tree source for TQ210 board.
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 as
+ * published by the Free Software Foundation.
+ */
+
+/dts-v1/;
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/interrupt-controller/irq.h>
+#include "s5pv210.dtsi"
+
+/ {
+       model = "Embedsky TQ210 based on S5PV210";
+       compatible = "embedsky,tq210", "samsung,s5pv210";
+
+       chosen {
+               bootargs = "console=ttySAC0,115200n8";
+       };
+
+       memory@20000000 {
+               device_type = "memory";
+               reg = <0x20000000 0x40000000>;
+       };
+
+       ethernet@88000000 {
+               compatible = "davicom,dm9000";
+               reg = <0x88000000 0x2 0x88000004 0x2>;
+               interrupt-parent = <&gph1>;
+               interrupts = <2 IRQ_TYPE_LEVEL_HIGH>;
+               local-mac-address = [00 00 de ad be ef];
+               davicom,no-eeprom;
+               clocks = <&clocks CLK_SROMC>;
+               clock-names = "sromc";
+       };
+};
+
+&xxti {
+       clock-frequency = <24000000>;
+};
+
+&uart0 {
+       status = "okay";
+};
+
+&nand {
+       status = "okay";
+       nand-ecc-mode = "soft";
+
+       partition@0 {
+               label = "boot";
+               reg = <0x0 0x40000>;            /* 246KB */
+               read-only;
+       };
+
+       partition@40000 {
+               label = "kernel";
+               reg = <0x40000 0x300000>;       /* 3MB */
+       };
+
+       partition@340000 {
+               label = "rootfs";
+               reg = <0x340000 0x3fcc0000>;    /* 1020MB */
+       };
+};
index 697d317c9f96fd9e7fac8a2d298c0d14654d7ee3..53509ef137f66eff9e7abe0a1f191232a6844c55 100644 (file)
@@ -13,14 +13,15 @@ define Device/Default
   PROFILES = Default
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | append-dtb | uImage none
+  DEVICE_DTS_DIR := ../dts
+  DEVICE_DTS = $$(SOC)_$(1)
 endef
 
-define Device/tq210
-  DEVICE_VENDOR := Samsung
+define Device/embedsky_tq210
+  DEVICE_VENDOR := EmbedSky
   DEVICE_MODEL := TQ210
-  DEVICE_DTS_DIR := ../dts
-  DEVICE_DTS := TQ210
+  SOC := s5pv210
 endef
-TARGET_DEVICES += tq210
+TARGET_DEVICES += embedsky_tq210
 
 $(eval $(call BuildImage))