ar71xx: further legacy image build fixes
authorJo-Philipp Wich <jo@mein.io>
Mon, 27 Jun 2016 13:03:57 +0000 (15:03 +0200)
committerJo-Philipp Wich <jo@mein.io>
Mon, 27 Jun 2016 13:15:49 +0000 (15:15 +0200)
- Add missing macro to trigger the generation of 64k padded squashfs images
- Revert Zcomax image generation to use the prepared 64k squashfs image

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/linux/ar71xx/image/legacy.mk

index 8446bcbb6f6fc5d765522ab3cd217c509d845086..c771f893ed48cb5a8bd3b292415ddf5e3f27b3fc 100644 (file)
@@ -919,7 +919,7 @@ define Image/Build/Zcomax
                $(STAGING_DIR_HOST)/bin/mkzcfw \
                        -B $(2) \
                        -k $(KDIR_TMP)/vmlinux-$(2).uImage \
-                       -r $(KDIR)/root.$(1) \
+                       -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
                        -o $(call imgname,$(1),$(2))-factory.img; \
        fi
 endef
@@ -1205,3 +1205,8 @@ define Image/Build/Profile
        $(call Image/Build/Profile/$(1),buildkernel)
        $(call Image/Build/Profile/$(1),$(2))
 endef
+
+# $(1): filesystem type.
+define Image/Build
+       $(call Image/Build/$(call rootfs_type,$(1)),$(1))
+endef