ramips: only limit lzma dictionary size on mt7621
authorJo-Philipp Wich <jo@mein.io>
Thu, 30 Aug 2018 08:51:09 +0000 (10:51 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 30 Aug 2018 08:57:35 +0000 (10:57 +0200)
The changed dictionary size leads to a different LZMA header which breaks
sysupgrade image magic checkibng on at least some RT288x boards.

Since the commit message only mentions testing on MT7621 and since the
change appears to break at least one other ramips subtarget, do not take
any chances and restrict the size limitation to only MT7621.

Fixes FS#1797
Fixes 09b6755946 ("ramips: limit dictionary size for lzma compression")
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/linux/ramips/image/Makefile
target/linux/ramips/image/mt7621.mk

index 5426226795280a15d291e4d96c78cfbc0e007bd9..9cf64361a4b15c319198d88f67fd537b9d6013c6 100644 (file)
@@ -31,7 +31,7 @@ loadaddr-$(CONFIG_TARGET_ramips_mt7621) := 0x80001000
 
 KERNEL_LOADADDR := $(loadaddr-y)
 
-KERNEL_DTB = kernel-bin | patch-dtb | lzma -d21
+KERNEL_DTB = kernel-bin | patch-dtb | lzma
 define Device/Default
   PROFILES = Default $$(DTS)
   KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)
index 4195c2269192b10739863869479c777951574816..a4a0f3d29382fb7c0b637c84c06adfd54269cfb7 100644 (file)
@@ -2,6 +2,7 @@
 # MT7621 Profiles
 #
 
+KERNEL_DTB += -d21
 DEVICE_VARS += TPLINK_BOARD_ID TPLINK_HEADER_VERSION TPLINK_HWID TPLINK_HWREV
 
 define Build/elecom-gst-factory